poj2299Ultra-QuickSort 分治归并

Ultra-QuickSort

 

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

思路:

跟51nod1019其实是一道题,输入不同而已

代码:

#include<cstdio>
#define ll long long
using namespace std;
const ll maxn = (int)5e5 + 10;
ll a[maxn],temp[maxn];
ll solve(ll l,ll r)
{
    ll ans = 0;
    ll mid = (l + r) >> 1;
    if (l == r)
        return 0;
    ans += solve(l,mid);
    ans += solve(mid + 1,r);
    for (ll i = l,j = mid + 1,pos = 0;i <= mid || j <= r;pos ++)
    {
        if (i > mid) temp[pos] = a[j ++];
        else if (j > r) temp[pos] = a[i ++];
        else  if (a[i] <= a[j]) temp[pos] = a[i ++];
        else
        {
            ans += mid - i + 1;
            temp[pos] = a[j ++];
        }
    }
    for (ll i = 0;i <= r - l;i ++)
        a[l + i] = temp[i];
    return ans;
}
int main()
{
    ll n;
    while (~scanf("%lld",&n) && n)
    {
        for (ll i = 0;i < n;i ++)
            scanf("%lld",&a[i]);
        ll ans = solve(0,n - 1);
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值