hdu1102 Constructing Roads Krustal最小生成树

Constructing Roads

 

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum. 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built. 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

思路:

emmmm这题坑点有点多,本来想用Prim写的,但是不太会,于是建图Krustal,中间find函数的if后面竟然失误的加了一个分号,找了一亿年并怀疑人生,在准备重写并已经写好头文件时突然想到肯定是if的问题,跑到尾一看果然是(大哭)

终于写好了样例也过了竟然WA了,心理阴影巨大,然后只能一遍一遍看代码想Bug,最后终于明白,已经给的连着的边可能有重边什么的,于是把优化又改了改,还是WA,这就是最坑的一点,题目并没说多组数据,而且描述的分明就是单组,像我这种老实人怎么会怀疑他!!!!!心累...............

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 110;
struct node
{
	int to,next,cost;
}a[10010];
bool cmp(node v,node u)
{
	return v.cost < u.cost;
}
int f[maxn];

int find(int x)
{
	if (x != f[x])
		f[x] = find(f[x]);
	return f[x];
}
int main()
{
	int n;
	while (~scanf("%d",&n))
	{	
		int q,t,pos = 0;
		for (int i = 1;i <= n;i ++)
			f[i] = i;
		for (int i = 1;i <= n;i ++)
			for (int j = 1;j <= n;j ++)
			{
				scanf("%d",&t);
				if (j > i)
				{
					a[pos].to = i,a[pos].next = j;
					a[pos ++].cost = t;
				}
			}
		sort(a,a + pos,cmp);
		scanf("%d",&q);
		int u,v;
		int cnt = 1,ans = 0;
		for (int i = 1;i <= q;i ++)
		{
			scanf("%d %d",&u,&v);
			int fx = find(u),fy = find(v);
			if (fx != fy)
			{
				cnt ++;
				f[fx] = fy;
			}
		}
		
		for (int i = 0;i < pos;i ++)
		{
			if (cnt == n)
				break;
			int fx = find(a[i].to);
			int fy = find(a[i].next);
			if (fx != fy)
			{
				f[fx] = fy;
				cnt ++;
				ans += a[i].cost;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值