POJ-1068解题报告





Online Judge Problem Set Authors Online Contests User
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist


Current Contest
Past Contests
Scheduled Contests
Award Contest
User ID:
Password:
  Register
Language:
Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13224 Accepted: 7865
Description


Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 


Following is an example of the above encodings: 


S (((()()())))


P-sequence    4 5 6666


W-sequence    1 1 1456




Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 
Input


The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output


The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input


2
6
4 5 6 6 6 6

4 6 6 6 6 8 9 9 9
Sample Output


1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
Source


Tehran 2001
[Submit]   [Go Back]   [Status]   [Discuss]


 Home Page   Go Back  To top


All Rights Reserved 2003-2011 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

#include <stdio.h>
int main()
{
    int n;
    int m, i, p, c;
    int a[20];
    int arr[20];
    scanf("%d", &n);
    while (n-- > 0) {
        p = 0;
        scanf("%d", &m);
        for (i = 0; i < m; i++) {
            scanf("%d", &a[i]);
            arr[i] = !i ? a[i] : a[i] - a[i - 1];
            p = arr[i] ? i : p;
            printf("%d", 1 + i - p);
            arr[p]--;
            while (!arr[p]) {
                p--;
            }
            if (i < m - 1) {
                printf(" ");
            } else {
                printf("\n");
            }
        }
    }
    return 0;
}

这道题还是比较简单的,可以在输入过程就把输出给确定了。每输入一个数,此位置之前有几个左括号,一个p标识符用于标识离当前位置最近的(包括当前位置)左括号数大于0的右括号位置,输出的值是当前位置与p位置差加1。具体原理就不多说了,看源码应该能比较容易理解。
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值