费马大定理与勾股数通式

费马大定理
由17世纪法国数学家皮耶·德·费马提出。

定理如下:

当整数n>2时,关于x,y,z的方程xn+yn+zn没有正整数解。

历经三百多年,最终在1995年,英国数学家安德鲁·怀尔斯宣布自己证明了费马大定理。

勾股数通式
当a,b作为直角边,c作为斜边时

若给出正整数a为偶数,b=(a×a÷2-2)÷2,c=(a*a÷2-2)÷2。若给出正整数a为奇数,b=(a×a-1)÷2,c=(a×a+1)÷2。

源于一道CCPC的问题,目前于HDU 6441题。
当时猜到了n>2时是我无解的,但没想出勾股数的通项公式,可惜了。

Find Integer

Description
people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input
one line contains one integer T;(1≤T≤1000000)
next T lines contains two integers,n,a(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5

AC代码

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    int i,j,t,a,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&a);
        if(n==0||n>2)
            printf("-1 -1\n");
        else
        if(n==1)
            printf("%d %d\n",a+1,2*a+1);
        else
        {
            if(a%2==0)
                printf("%d %d\n",(a*a/2-2)/2,(a*a/2+2)/2);
            else
                printf("%d %d\n",(a*a-1)/2,(a*a+2)/2);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值