Chinese Zodiac---ACM青岛Regional

Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2451    Accepted Submission(s): 1645


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon
 

Sample Output
  
  
8 4 12
题目大意分析: 维多利亚与一个年轻人结婚 ,所以维多利亚的年龄比丈夫的年龄大,在输入生肖时,如果维多利亚的生肖在丈夫的后面,则丈夫的生肖在下一轮中
#include<stdio.h>
#include<string.h>
#include<math.h>
struct ar{
	char arr[12];	
}
stu[12]={"rat","ox","tiger","rabbit","dragon","snake",
"horse","sheep","monkey","rooster","dog","pig"};//将十二生肖放在结构体数组中 
struct nu{
	char a[10];
	char b[10];//定义输入的两个生肖 
}s;
int main(){

	int n;
	scanf("%d",&n);
		while(n--){
			int i,c,d;
		scanf("%s%s",&s.a,&s.b);
			if(strcmp(s.a,s.b)==0)//如果两个生肖相等,直接输出12 
			{
				printf("12\n");
				continue;
			}
			for(i=0;i<12;i++)//在存放生肖的结构体数组中找到与输入的生肖相同的, 
		{						// 并将下标存放在c,d中 
			if(strcmp(s.a,stu[i].arr)==0)
			{
				c=i;
			}
			if(strcmp(s.b,stu[i].arr)==0)
			{
				d=i;
			}
			
		}
		if(c>d)
		{
			printf("%d\n",12-abs(c-d));//丈夫的生肖比维多利亚小的情况 
		}
		else printf("%d\n",abs(c-d));//丈夫的生肖比维多利亚大的情况
		
		}
		
		
	return 0;
} 



  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值