POJ1002

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.
 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

 

310-1010 2487-3279 4888-4567 3

 

这算是复试之后开始刷的第一题了,感觉很多东西都开始不熟悉并且很多基础被我遗忘了,以后还是得每天练一练保持感觉啊。

对于这道题,我一开始想构造一个结构体数组,保存每个号码的内容和出现次数,每输入一个号码就遍历数组看有没有重复的。结果后来总是超时,然后学习了网上的思路,直接先一次把所有的号码按规范存入数组,然后排序,再遍历一次数组寻找重复出现的并输出,因为已经按字典序排好了,所以时间复杂度可以控制在n以内。

 

#include<stdio.h>
#include<iostream> 
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
string s[100000];
char judge[]="22233344455566670778889990";
int main()
{
	int n;
	scanf("%d",&n);
	getchar();
	for(int j=0;j<n;j++)
	{
		char t[20];
		char tmp[20];
		scanf("%s",t);
		int len=strlen(t);
		int cnt=0;
		for(int i=0;i<len;)
		{
			if(cnt!=3)
			{
				if(t[i]>='0'&&t[i]<='9')
				{
					tmp[cnt++]=t[i];
				}
				else if(t[i]>='A'&&t[i]<='Z')
				{
					tmp[cnt++]=judge[t[i]-'A'];
				}
				i++;
			}
			else
			{
				tmp[cnt++]='-';
			}
			if(cnt==9)
				break;
		}
		tmp[cnt]=0;
		s[j]=tmp;
	}
	sort(s,s+n);
	bool flag=false;
	int count=1;
	for(int i=1;i<=n;i++)
	{
		if(s[i]!=s[i-1])
		{
			if(count>1)
			{
				cout<<s[i-1]<<" "<<count<<endl;
				flag=true;
			}
			count=1;
		}
		else
			count++;
	}\\这地方要循环到i=n,不然会有遗漏
	if(flag==false)
		printf("No duplicates.\n");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值