POJ1065-dilworth定理?

Wooden Sticks

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25985 Accepted: 11248

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

这道题做完还有些晕乎,我自己用的解法如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct wooden{
	int l,w;
	bool operator < (const wooden &A)const{
	if(l==A.l)
		return w<A.w;
	return l<A.l;
	}
}wo[5001];
int mark[5001];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		memset(mark,0,sizeof(mark));
		memset(wo,0,sizeof(wo));
		for(int i=0;i<n;i++)
			scanf("%d%d",&wo[i].l,&wo[i].w);
		sort(wo,wo+n);
		int flag;
		int count=0;
		for(int i=0;i<n;i++)
		{
			if(!mark[i])
			{
				flag=wo[i].w;
				mark[i]=1;
				for(int j=i+1;j<n;j++)
				{
					if(wo[j].w>=flag&&mark[j]==0)
					{
						mark[j]=1;
						flag=wo[j].w;
					}
				}
				count++;
			}
		}
		printf("%d\n",count);
	}
	return 0;
}

还有另一种解法用到了dilworth定理,即最长不下降子序列的个数等于最长下降子序列的长度,为什么如此嘛,我也不太懂,等以后弄明白吧。https://blog.csdn.net/qq_29169749/article/details/52517853

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值