HUD 5056 Boring count

Boring count


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 
Input
  
  
In the first line there is an integer T , indicates the number of test cases. For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K. [Technical Specification] 1<=T<= 100 1 <= the length of S <= 100000 1 <= K <= 100000
 
Output
  
  
For each case, output a line contains the answer.
 
Sample Input
  
  
3 abc 1 abcabc 1 abcabc 2
 
Sample Output
  
  
6 15 21



思路:O(n)的算法,枚举i,求出以每个i结尾的满足条件的串的个数,即以i结尾的最长串的长度。


源代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

#define N 111111
using namespace std;

typedef long long LL;

char str[100001];
int cnt[30];
int k;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>(str+1)>>k;
        memset(cnt,0,sizeof cnt);
        int n=strlen(str+1);
        int pos=0;
        LL res=0;
        for(int i=1;i<=n;i++)
        {
            cnt[str[i]-'a']++;
            if(cnt[str[i]-'a']>k)
            {
                pos++;
                while(str[pos]!=str[i])
                {
                    cnt[str[pos]-'a']--;
                    pos++;
                }
                cnt[str[pos]-'a']--;
            }
            res+=i-pos;
        }
        printf("%I64d\n",res);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: 要在 BoringSSL 中设置随机数,你可以使用 `RAND_set_rand_method` 函数来设置随机数生成器的实现。这个函数需要一个指向 `RAND_METHOD` 结构体的指针,这个结构体包含了用于生成、清除和添加随机数种子的函数。你可以使用 BoringSSL 提供的默认实现,也可以自己实现这个结构体来提供自定义的随机数生成方式。 示例代码如下: ``` #include <openssl/rand.h> RAND_METHOD fake_rand_method; int fake_rand_bytes(unsigned char *buf, int num) { // 在这里实现生成 num 个字节的随机数的逻辑 return 1; } void fake_rand_cleanup(void) { // 在这里实现清除随机数种子的逻辑 } int fake_rand_add(const void *buf, int num, double entropy) { // 在这里实现添加随机数种子的逻辑 return 1; } int fake_rand_status(void) { // 在这里实现返回随机数生成器的状态的逻辑 return 1; } int main() { fake_rand_method.bytes = fake_rand_bytes; fake_rand_method.cleanup = fake_rand_cleanup; fake_rand_method.add = fake_rand_add; fake_rand_method.status = fake_rand_status; RAND_set_rand_method(&fake_rand_method); // 现在 BoringSSL 会使用 fake_rand_method 中定义的函数来生成随机数 return 0; } ``` 注意,如果你使用的是 BoringSSL 的 C++ 封装(也就是 `boringssl::RAND` 类),那么你可以 ### 回答2: boringssl是一个用于加密和安全传输的开源软件库,其随机数的设置是非常重要的。 在boringssl中,可以通过以下步骤来设置随机数: 1. 初始化随机数引擎:首先,需要使用一个随机数引擎来生成随机数。boringssl使用Crypto::Rand类来生成随机数,可以通过调用Crypto::Rand::Init()函数来初始化随机数引擎。 2. 获取随机数:一旦随机数引擎被初始化,可以使用Crypto::Rand::Bytes()函数来获取指定长度的随机数。该函数将生成的随机数存储在指定的内存位置中。 3. 设置随机数回调函数:为了更好地控制随机数的生成过程,boringssl还提供了设置随机数回调函数的功能。可以通过调用CRYPTO_set_rand_bytes_callback()函数来设置随机数回调函数,该函数接受一个函数指针作为参数,用于指定随机数的生成方式。 通过以上步骤,可以在boringssl中设置随机数。这样做是为了确保加密算法中使用的随机数具有足够的随机性和安全性,以提高加密和安全传输的效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值