Ultra-QuickSort——归并排序

Ultra-QuickSort
Time Limit:7000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
   
题意:
给出一组数,让这组数从小到大排序,问交换的次数
 
   
因为数据比较大,用归并排序能够保证不超时
 
   
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int a[500009],L[500009],R[500009];
__int64 s;
void Merge(int l,int r,int m)
{
    int i,j,k;
    int n1=m-l+1;
    int lenl = 0,len2 = 0;
    for(i = l;i <= m;i++)
        L[lenl++] = a[i];
     for(i = m + 1;i <= r;i++)
        R[len2++] = a[i];
        L[lenl] = 99999999;
        R[len2] = 99999999;
        for(i = 0,j = 0,k = l;k <= r;k++)//以两个为一单元进行归并排序
        {
            if(L[i] <= R[j])
                a[k] = L[i],i++;
                else
                    {
                        a[k] = R[j],j++;
                        s+=n1-i;//只要发现前边的有一个比后边的大,则从前变得这一个起,到最后都要与那个小的进行交换,次数增加
                    }

        }
}

void merge_sort(int s,int t)
{
    if(s < t)
    {
        int m = (s + t)/2;
        merge_sort(s,m);//将原数组拆分成最小单元
        merge_sort(m+1,t);
        Merge(s,t,m);
    }
}

int main()
{
    int n;
    int i,j,k;
    while(scanf("%d",&n),n)
    {
        s=0;
        for(i = 0;i < n;i++)
            scanf("%d",&a[i]);
        merge_sort(0,n-1);
        printf("%I64d\n",s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值