poj 2586 Y2K Accounting Bug——我感觉是枚举(分类是贪心)



Y2K Accounting Bug
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 9776
Accepted: 4870

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source


这个题我感觉考察的核心是对题目的理解,自己看了好长时间,然后用翻译软件翻译了好长时间,还是不懂,问了问AC这道题的队员,才明白:一个公司一年十二各月中每连续五个月的营业额代数和都是负数,每个月如果盈利就是是,亏损就是d,问满足上述条件,一年内总的营业额有没有可能是盈利,如果有,输出最大的盈利,如果不行,打印Deficit。

一开始根本就没有思路,这也是poj的特点吧,但是用第一组数据理解一下题,多少有些眉目了

月份1   2   3   4   5   6   7   8   9   10    11   12

情况盈  盈  盈   盈  亏  盈   盈  盈   盈   亏    盈   盈

这样59*10-237*2=116正好合题意,如果继续推下去

月份1   2   3   4   5   6   7   8   9   10    11   12

情况盈  盈  盈   亏  盈  盈   盈  亏   盈   盈    盈   亏

盈利情况是s*9-d*3,如果这个结果>0的话,就又出现了一种情况,继续分析

月份1   2   3   4   5   6   7   8   9   10    11   12

情况盈  盈  亏   盈  盈  亏   盈  盈   亏  盈     盈   亏

盈利情况是s*8-d*4, 如果这个结果>0的话,就有出现了了一种情况,继续分析

.

.

.

.

.

当你分析完的时候,就有四种情况出现了:

实现为:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>


int main()
{
    int s,d,ls;
    while(~scanf("%d%d",&s,&d))
    {
        if(4*d>s&&s*3-d*9>0)
        {
            ls=s*3-d*9;
        }
        else if(3*d>2*s&&s*6-d*6>0)
        {
            ls=s*6-d*6;
        }
        else if(2*d>3*s&&s*8-d*4>0)
        {
            ls=s*8-d*4;
        }
        else if(d>4*s&&s*10-d*2>0)
        {
            ls=s*10-d*2;
        }                         //把上述四种情况考虑到就是ok了
        else
        {
            printf("Deficit\n");
            continue;
        }
        printf("%d\n",ls);


    }
    return 0;
}

这个题看起来很简单,但是很考察思维......






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值