hdoj 1116 Play on Words——并查集+欧拉图

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5516    Accepted Submission(s): 1808


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
 

Source


欧拉路判定条件:

一个有向图具有单项欧拉路,当且仅当它是联通的,而且除两个节点外,每个节点的入度等于出度,但这两个节点中,一个节点的出度比入度大1,另一个节点的入度比出度大1.(《离散数学》左孝凌 等编著);


#include <stdio.h>
#include <string.h>

int rd[27];//统计入度
int cd[27];//统计出度
int s[27];//并查集数组
char str[1010];//输入的单词数组

int nfind(int x)//并查集查找数组
{
    int r = x,q;
    while(x != s[x])
        x = s[x];
    while(s[r] != x)
    {
        q = s[r];
        s[r] = x;
        r = q;
    }
    return x;
}

void lj(int x,int y)//并查集连接两个点的数组
{
    int fx = nfind(x);
    int fy = nfind(y);
    if(fx != fy)
    {
        s[fx] = fy;
    }
}

int main()
{
    int t,n,l,f1,f2,f3,x,y;
    scanf("%d",&t);
    while(t--)
    {
        for(int i = 1; i < 27; i++)
        {
            s[i] = i;
        }//初始化并查集数组
        memset(cd,0,sizeof(cd));
        memset(rd,0,sizeof(rd));
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%s",str);
            l = strlen(str);
            x = str[0] - 'a' + 1;
            y = str[l - 1] - 'a' + 1;//把头字母和尾字母转换成数字
            cd[x]++;//头字母的出度+1
            rd[y]++;//尾字母的入度+1
            lj(x,y);//连接头字母和尾字母
        }
        int js = 0;
        for(int i = 1; i < 27; i++)
        {
            if((cd[i] || rd[i]) && s[i] == i)
            {
                js++;
            }
        }
        if(js > 1)//如果输入的字母存在并且他们有两或以上个根节点(说明有不连通的)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        f1 = 0;
        f2 = 0;
        f3 = 0;
        for(int i = 1; i < 27; i++)
        {
            if(rd[i] - cd[i] == 1)//统计入度比出度大一的点的个数
            {
                f1++;
            }
            else if(cd[i] - rd[i] == 1)//统计入度比出度小一的点的个数
            {
                f2++;
            }
            else if(cd[i] == rd[i])  //统计点相等的个数
                f3++;
        }
        if(f1 == 1 && f2 == 1 && f1 + f2 + f3 == 26)
        {
            printf("Ordering is possible.\n");
        }
        else if(f1 == 0 && f2 == 0 && f3 == 26)
        {
            printf("Ordering is possible.\n");
        }
        else
        {
            printf("The door cannot be opened.\n");
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值