堆应用The kth great number

题目介绍The kth great number

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3




Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

这个题目的意思是,我不停的告诉你数字,然后问你我告诉你的这一大堆数字中,第K的数字是哪一个,输入I 的熟识输入数字,输入Q的时候输出答案,这个题分析显然是对堆的性质的最好应用,创建一个堆,因为堆为单调的,所以堆顶的元素必为最大或者最小,这个题要求求第K的元素,显然就可以维护一个大小为K的堆,从小到大排列堆顶元素就是第K小的元素,对于这个堆的维护,是这样的,当输入的这个数比堆顶元素还小的时候,显然就没有入堆的必要了,当这个元素比堆顶元素大,然后就将这个元素入堆,弹出堆顶元素,这样就可以使堆的元素各入一直保持为K。

AC代码

#include<cstdio>
#include<queue>
#include<vector>
using namespace std;

int main()
{
	
    int n,k,i,q,j;
    char s[2]; 
	while(scanf("%d%d",&n,&k)!=EOF)
	{
	priority_queue<int,vector<int>,greater<int>> qi;
		for(i=1;i<=n;i++)
		{
			scanf("%s",&s);
			if(s[0]=='I')
			{
				scanf("%d",&q);
				qi.push(q);
				if(qi.size()>k)
				{
					qi.pop();
				}
			}
			if(s[0]=='Q')
			{
				printf("%d\n",qi.top());
			}
			
		}
	
	}
	return 0;
 } 


 


       


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值