Exponentiation

Problemsinvolvingthecomputationofexactvaluesofverylargemagnitudeandprecisionarecommon. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number (0.0 < R < 99.999) and n is an integer such that 0 < n ≤ 25. Input The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. Output The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.(去掉前导零和后导零)

Sample Input

95.123 12

0.4321 20

5.1234 15

6.7592 9

98.999 10

1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672

90429072743629540498.107596019456651774561044010001 

1.126825030131969720661201

 

BigDecimal 和 BigInteger 用法一样

大数的循环

BigInteger one = new BigInteger("1");  //   大数类型的常数 1 的定义

while(n.compareTo(one)>=0){

           代码

           n=n.subtract(one);

}

前导零和后导零的处理方法:

String str;

str = ans.stripTrailingZeros().toPlainString();

if(str.charAt(0)=='0')

             System.out.println(str.substring(1));

else

             System.out.println(str);

 

substring():(截取字符串)

public String substring(int beginIndex, int endIndex)

第一个int为开始的索引,对应String数字中的开始位置,

第二个是截止的索引位置,对应String中的结束位置

1、取得的字符串长度为:endIndex - beginIndex;

 

java  的 str.charAt(0) 类似 c 的 s[0];

 

import java.util.*;
import java.math.*;
public class Main {
	public static BigDecimal Bigpow ( BigDecimal m, BigInteger n){
		BigInteger one = new BigInteger("1");
		BigDecimal ans = new BigDecimal("1"); 
		while(n.compareTo(one)>=0){
			ans = ans.multiply(m);
			n=n.subtract(one);
		}
		return ans;
	}
	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
		BigDecimal s,ans;
		BigInteger a;
		while(cin.hasNext())
		{
			s=cin.nextBigDecimal();
			a=cin.nextBigInteger();
			ans=Bigpow(s,a);
			String str;
			str = ans.stripTrailingZeros().toPlainString();
			if(str.charAt(0)=='0')
				System.out.println(str.substring(1));
			else
				System.out.println(str);
		}		
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值