1065 A+B and C (64bit) (20 point(s))
Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true
if A+B>C, or Case #X: false
otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
不得不说,PAT是一个非典型的编程测试。这个题居然和计算机ALU实际进行加法的原理扯上了关系。
对于long long int,可以表达的范围正好是,虽然在两个数同号的时候,它们的和可能不能表示,但是我们可以根据和的正负分别判断出现正溢出或者负溢出。 (参考《汇编程序语言设计》)
1. 当A>0,B>0,A+B<0时为正溢出,此时输出true。
2. 当A<0,B<0,A+B>=0时,为负溢出,此时输出false。
#include<iostream>
#define LL long long
using namespace std;
bool judge(LL a,LL b,LL c){
LL sum = a+b;
if(a>0&&b>0&&sum<0) return true;//正溢出
else if(a<0&&b<0&&sum>=0) return false;//负溢出
else if(sum>c) return true;//没有发生溢出
else if(sum<=c) return false;//同上
}
int main(void){
int T;
cin>>T;
LL a,b,c;
for(int i=0;i<T;i++){
cin>>a>>b>>c;
cout<<"Case #"<<i+1<<": ";
if(judge(a,b,c)) cout<<"true"<<endl;
else cout<<"false"<<endl;
}
return 0;
}
1. int和LL的表示范围:https://blog.csdn.net/gotowu/article/details/51203920
2. 参考链接:https://blog.csdn.net/richenyunqi/article/details/80110078