1082 Read Number in Chinese

1082 Read Number in Chinese (25 point(s))

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

这是一道比较复杂的模拟题。

中文中读数是按照4位一读,read()函数实现。关键是0的处理,包括4位中前置0的处理(read()中实现)、4位中间的0的处理(主程序中实现)、末尾0的处理(不需要处理)。

 

#include<iostream>
using namespace std;
string words[110];
string digit[10]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
int idx = 0;
void read(int n){
	int thousand,hundred,tens,ones;
	thousand = n/1000;
	n = n - thousand*1000;
	hundred = n/100;
	n = n - hundred*100;
	tens = n / 10;
	ones = n % 10;
	bool flag=false;
	if(thousand!=0){
		words[idx++]=digit[thousand];
		words[idx++]="Qian";
		if(hundred==0&&(tens>0||ones>0)){
			words[idx++]=digit[0]; 
		}
	}
	if(hundred!=0){
		words[idx++]=digit[hundred];
		words[idx++]="Bai";
		if(tens==0&&ones>0) words[idx++]=digit[0];
	}
	if(tens!=0){
		flag=false;
		words[idx++]=digit[tens];
		words[idx++]="Shi";
	}
	if(ones!=0) words[idx++]=digit[ones];
}
int main(void){
	int n;cin>>n;
	if(n<0) {
		words[idx++]="Fu";
		n=-n;
	}
	if(n==0) words[idx++]=digit[0];
	int hm=0,tt=0;
	if(n>=100000000){
		hm = n/100000000;
		words[idx++]=digit[hm];
		words[idx++]="Yi";
		n = n-hm*100000000;
	}
	if(n>=10000){
		tt = n/10000;
		if(hm>0&&tt<1000&&tt>0) words[idx++]=digit[0];//前置0 
		read(tt);
		words[idx++]="Wan";
		n = n-tt*10000;
	}
	if(n>0){
		if((tt>0||hm>0)&&n<1000&&n>0) words[idx++]=digit[0];
		read(n);
	}
	for(int i=0;i<idx;i++){
		if(i==0) cout<<words[i];
		else cout<<" "<<words[i];
	}
	cout<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值