1081 Rational Sum (20 point(s))

1081 Rational Sum (20 point(s))

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

较复杂模拟题。思路见注释。注意点:最小公约数和最大公倍数的求解;2.引用作为形参。 

#include<iostream>
#define ll long long
using namespace std;
ll numer[107],deno[107];//分子,分母
ll c = 0; 
ll comfactor(ll a,ll b){//求公因数 
	if(a%b==0) return b;
	else return comfactor(b,a%b);
}
ll commul(ll a,ll b){//求公倍数 
	return a*b/comfactor(a,b);
}
void simplify(ll &num,ll &den){//将假分数转化为真分数,并记录系数 
	ll coe = num/den; c+=coe;
	num -= den*coe;
	if(num==0){
		den=1;return;
	}
	ll cf = comfactor(num,den);
	num/=cf;den/=cf;
}
int main(void){
	int N;cin>>N;
	for(int i=0;i<N;i++){
		scanf("%lld/%lld",&numer[i],&deno[i]);
		simplify(numer[i],deno[i]);//读入并化解 
	}
	ll mul=1;
	for(int i=0;i<N;i++){
		mul =commul(mul,deno[i]);//根据真分数部分,求出分母(反复采用最小公倍数公式) 
	}
	ll num=0;
	for(int i=0;i<N;i++){
		num=num+numer[i]*(mul/deno[i]);//根据最小公倍数得到的分母计算分子 
	}
	simplify(num,mul);//化解 
	/*根据整数部分、分数部分情况,输出结果*/ 
	if(c!=0) cout<<c;
	if(num!=0){
		if(c!=0) cout<<" ";
		cout<<num<<"/"<<mul;
	}
	if(c==0&&num==0) cout<<"0";
	cout<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值