1080 Graduate Admission

1080 Graduate Admission (30 分)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G​E​​and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

模拟题。此题按照流程来即可,比较巧妙的点

1. 名次赋值;

2. 最低录取线。在每个招生单位招生完成(刚好达到规定名额)以后,设定最低录取名次线。如果后面的拥有相同名次申请者申请该招生单位,即使满额也要录取;

3. 要注意每个申请者最多被一个招生单位录取。

注意点:排序时,高分排在前面;

#include<iostream>
#include<vector>
#include<algorithm> 
using namespace std;
struct app{
	int id,ge,gi;int v[5];int rank;
	bool operator < (const app &other) const{
		if(ge+gi!=other.ge+other.gi) return ge+gi>other.ge+other.gi;
		else return ge>other.ge;
	}
};
int quota[107];//名额 
int pass[107]={0};//已录取人数 
int line[107];//最低录取排名数 
vector<int> adm[107];//录取名单 
vector<app> a;//申请者 
int main(void){
	int N,M,K;cin>>N>>M>>K;//N 学生数 M 招生单位 K 志愿数 
	for(int i=0;i<M;i++) cin>>quota[i];
	app temp;
	for(int i=0;i<N;i++){
		cin>>temp.ge>>temp.gi;
		for(int j=0;j<K;j++) cin>>temp.v[j];
		temp.id = i;
		a.push_back(temp);
	}
	sort(a.begin(),a.end());
	for(int i=0;i<N;i++){//排名赋值 
		if(i==0) a[i].rank = 0;
		else if(a[i].ge==a[i-1].ge&&a[i].gi==a[i-1].gi)  a[i].rank = a[i-1].rank;
		else a[i].rank = i; 
	}
	//for(int i=0;i<N;i++) 	cout<<a[i].ge<<" "<<a[i].gi<<" "<<a[i].rank<<endl;
	for(int i=0;i<N;i++){
		for(int j=0;j<K;j++){
			int curId = a[i].id;
			int curV = a[i].v[j];//志愿学校 
			int curRank = a[i].rank; 
			if(pass[curV]<quota[curV]){//尚有名额 
				pass[curV]++;
				adm[curV].push_back(curId);
				if(pass[curV]==quota[curV]){//录取完成,设定最低录取线 
					line[curV] = curRank; 
				} 
				break;//每个人只可能被一个招生单位录取 
			}
			else{//已经没有名额了 
				if(curRank==line[curV]){//但是达到最低名次线 
					pass[curV]++;
					adm[curV].push_back(curId);
					break;//每个人只可能被一个招生单位录取 
				} 
			}
		} 
	} 
	for(int i=0;i<M;i++){
		sort(adm[i].begin(),adm[i].end());
		for(int j=0;j<adm[i].size();j++){
			if(j==0) cout<<adm[i][j];
			else cout<<" "<<adm[i][j];
		}
		cout<<endl;
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值