1044 Shopping in Mars (25 point(s))

1044 Shopping in Mars (25 point(s))

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains Npositive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意分析:给出一个数组,使得区间和恰好等于某个给定的数值。如果不存在,则找出区间和大于该区间和但是尽可能小的。

方法1:二分查找

根据给定数组,求出前i项和数组(一定是不递减数组),然后使用二分查找。注意寻找的是第一个大于或者等于key的数值。

易错点:在查询过程find()中,由于数组sum[]可能不存在大于sum[i]+M(会返回最后一个元素的下标N),由此main()中必须要重新确定找到的这个下标是满足sum[j]-sum[i]>=M。也可以改进在find()中去判断,如果不满足则返回-1。

#include<iostream>
#include<vector>
#include<cstring>
#define MIN 0x3f3f3f3f
using namespace std; 
const int MAX = 1e5+7;
int N,M;
int a[MAX]={0};
int sum[MAX]={0};//前i个元素的和 
void init(){
	for(int i=1;i<=N;i++) sum[i]=sum[i-1]+a[i];
}
struct Pair{
	int a;int b;
	Pair(int x,int y):a(x),b(y){};
};
int find(int sum[],int left,int right,int key){//二分查找 
	int mid;
	while(left<right){
		mid = left+(right-left)/2;
		if(sum[mid]>=key) right = mid;
		else left=mid+1;
	}
	return left;
}
vector<Pair> v;
int main(void){
	cin>>N>>M;//数组元素个数、目标金额 
	for(int i=1;i<=N;i++) cin>>a[i];
	init(); v.clear();
	int min = MIN;
	for(int i=0;i<N;i++){
		int j = find(sum,i+1,N,sum[i]+M);
		if(sum[j]-sum[i]>=M&&sum[j]-sum[i]<min){
			min = sum[j]-sum[i];
			v.clear();
			v.push_back(Pair(i+1,j));
		}
		else if(sum[j]-sum[i]>=M&&sum[j]-sum[i]==min){
			v.push_back(Pair(i+1,j));
		}
	}
	for(int i=0;i<v.size();i++) cout<<v[i].a<<"-"<<v[i].b<<endl; 
	return 0; 
}

方法2:双指针

设定两个分别指向区间首尾元素的指针i和j,用sum表示该区间和。

当i确定时,如果sum<M,则说你区间还不够长,因此应当向右扩大范围;如果sum>=M,则说明这是在i确定的情况下,满足基本要求(sum>=M且最接近M),再进一步判断,然后i自增。直到i和j都是N了。

心得:变量命名和含义一定要符合自己的编码习惯。

#include<iostream>
#include<vector>
#define MIN 0x3f3f3f3f
using namespace std; 
const int MAX = 1e5+7;
int N,M;
int a[MAX]={0};
struct Pair{
	int a;int b;
	Pair(int x,int y):a(x),b(y){};
};
vector<Pair> v;
int main(void){
	cin>>N>>M;//数组元素个数、目标金额 
	for(int i=1;i<=N;i++) cin>>a[i];
	int sum = a[1];//当前元素i(含)到j的和(含) 
	int min = MIN;
	for(int i=1,j=1;i<=N&&j<=N;){
		if(sum<M){
			j++;
			sum+=a[j];
		}
		else{
			if(sum<min){
				min = sum;
				v.clear();
				v.push_back(Pair(i,j));
			}
			else if(sum==min){
				v.push_back(Pair(i,j));
			}
			sum-=a[i]; 
			i++;
		}
	} 
	for(int i=0;i<v.size();i++) cout<<v[i].a<<"-"<<v[i].b<<endl; 
	return 0; 	
} 

参考链接:https://blog.csdn.net/richenyunqi/article/details/79323796

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值