1093 Count PAT's (25 point(s))

1093 Count PAT's (25 point(s))

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

直接暴力搜索必然会TLE,复杂度已经达到了o(n^3) ,这是不可以接受的。

此时换一个思路,在字符串中遍历A。当A固定的时候,其可以组成PAT的数量是之前的P的数量乘以之后T的数量。这样只需要维护两个数组,保存P和T的个数和即可,复杂度降到了o(n)

#include<iostream> 
#include<cstring>
using namespace std;
const int MOD = 1000000007;
const int LEN = 1e5+7;
int Pcnt[LEN]={0};
int Tcnt[LEN]={0};
int main(void){
	string s;cin>>s;
	for(int i=0;i<s.length();i++){
		if(s[i]=='P'){
			if(i==0) Pcnt[i]=1;
			else Pcnt[i]=Pcnt[i-1]+1;
		}
		else{
			if(i==0) Pcnt[i]=0;
			else Pcnt[i]=Pcnt[i-1];
		}
		if(s[i]=='T'){
			if(i==0) Tcnt[i]=1;
			else Tcnt[i]=Tcnt[i-1]+1;
		}
		else{
			if(i==0) Tcnt[i]=0;
			else Tcnt[i]=Tcnt[i-1];
		}
	}
	int sum =0;
	for(int i=1;i<s.length()-1;i++){
		if(s[i]=='A'){
			sum = (sum+Pcnt[i-1]*(Tcnt[s.length()-1]-Tcnt[i]))%MOD;
		}
	}
	cout<<sum<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值