1043 Is It a Binary Search Tree (25 point(s))

1043 Is It a Binary Search Tree (25 point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then Ninteger keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意:

给出BST的前序遍历和BST及其镜像树的定义,判断其是否合法,若合法输出其后序遍历。

考点:

1. 二叉搜索树的定义和建立;

2. 树的前序遍历、后续遍历;

3. 根据二叉搜索树的递归定义,左子树的结点值都小于根结点,右子树的结点值都大于等于根结点(镜像树相反)可知,仅通过其前序遍历(根--左子树--右子树),就可以唯一确定树的结构,按照顺序插入元素即可。

思路:

基于3可知:

1. 首先判断树是BST还是其镜像树,假设其是给出的先序遍历是正确的,按顺序插入元素建树;

2. 对所建立的BST进行前序遍历,并和给出的比较;

3. 若相同,则假设成立,再对树进行后序遍历,否则假设错误。

注意点和值得学习的点:

通过引用把遍历结果记录再vector中(常规思路,但是有时候不容易想到);

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
struct Node{
	int data;Node* left;Node* right;
	Node(int d):data(d),left(NULL),right(NULL){ }
};
bool mirror = false;
void insert(Node* &root,int data){//注意是引用 
	if(root == NULL){//根节点是空,建立新节点 
		root = new Node(data);
		return;
	}
	if(mirror==false){//是二叉搜索树 
		if(data < root->data) insert(root->left,data);
		else insert(root->right,data); 
	} 
	else{//是二叉搜索树镜像树 
		if(data >= root->data) insert(root->left,data);
		else insert(root->right,data);
	}
}
void preOrder(Node* root,vector<int>& order){//二叉树的先序遍历 
	order.push_back(root->data);
	if(root->left!=NULL) preOrder(root->left,order);
	if(root->right!=NULL) preOrder(root->right,order);
} 
void postOrder(Node* root,vector<int>& order){//二叉树的后序遍历 
	if(root->left!=NULL) postOrder(root->left,order);
	if(root->right!=NULL) postOrder(root->right,order);
	order.push_back(root->data); 
} 
int main(void){
	int N,a;cin>>N;
	vector<int> preGot,preGiven,post;
	Node* root = NULL;
	for(int i=0;i<N;i++){
		cin>>a;
		preGiven.push_back(a);
	}
	if(preGiven.size()>1&&preGiven[1]>preGiven[0]) mirror = true;
	for(int i=0;i<N;i++){
		insert(root,preGiven[i]);
	}
	preOrder(root,preGot);
	if(preGot==preGiven){//如果根据给出的序列生成的二叉搜索树和实际建树遍历的一致,则说明输入合法 
		postOrder(root,post);
		cout<<"YES"<<endl;
		for(int i=0;i<post.size();i++){
			if(i==0) cout<<post[i];
			else cout<<" "<<post[i];
		}
	}
	else cout<<"NO"<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值