1019 General Palindromic Number

1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

回文数问题和进制转换属于机考的常规题,要注意根据数值范围来确定解题方法。如进制转换有常规方法(int内)和大数方法(模拟除法)。

#include<iostream>
using namespace std;
int a[101];
int dec2b(int n,int base,int arr[]){
	int idx=0;
	while(n!=0){
		arr[idx]=n%base;
		n/=base;
		idx++;
	}
	return idx;
}
int b2dec4rev(int arr[],int base,int len){
	int ans=0;
	for(int i=0;i<len;i++){
		ans=ans*base+arr[i];
	}
	return ans;
}
int main(void){
	int n,base;
	cin>>n>>base;
	int len=dec2b(n,base,a);
	int reverse = b2dec4rev(a,base,len);
	if(n==reverse) cout<<"Yes"<<endl;
	else cout<<"No"<<endl;

	for(int i=len-1;i>=0;i--){
		if(i==len-1) cout<<a[i];
		else cout<<" "<<a[i]; 
	}

	return 0;
	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值