线段树区间修改,区间(单点)查询 poj2777 线段树上色

                                               Count Color

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

操作:1:把区间 l - r 改成颜色 x      2: 查询区间 l - r 的颜色种类

涉及操作:区间修改 lazy标记;区间查询;

这里的区间查询和我前面遇到的似乎有点不同;

这里的一个结点如果是-1,那么说明他的子树颜色有多种,如果不是-1,表示的是他的子树所有叶子的颜色一样;

所以这里实际应该还是一个单点查询,只不过是一个区间的单点值;

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<set>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<cmath>
using namespace std;
const int INF=0x7f7f7f7f;
const int maxn=1e5+5;
struct node
{
    int id;
}b[maxn<<2];
int vis[40];
void down(int l,int r,int rt)
{
    if(b[rt].id!=-1)
    {
        b[rt<<1].id=b[rt<<1|1].id=b[rt].id;
        b[rt].id=-1;
    }
}
void build (int l,int r,int rt)
{
    b[rt].id=1;
    if(l==r) return ;
    int mid=(l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
}
void change(int l,int r,int rt,int ll,int rr,int c)
{
    if(ll<=l&&r<=rr)
    {
        b[rt].id=c;
        return ;
    }
    down(l,r,rt);
    int mid=(l+r)>>1;
    if(mid < ll) change(mid+1,r,rt<<1|1,ll,rr,c);//往右找
    else if(mid >= rr) change(l,mid,rt<<1,ll,rr,c);
    else
    {
        change(l, mid, rt<<1, ll,mid,c );
        change(mid + 1, r, rt<<1|1, mid+1 , rr, c );
    }
}
void query(int l,int r,int rt,int ll,int rr)
{
    if(b[rt].id!=-1)
    {
        vis[b[rt].id]=1;
        return ;
    }
    if(l==r)
    {
        //vis[b[rt].id]=1;
        return;
    }
    int mid=(l+r)>>1;
    if(mid < ll) query(mid+1,r,rt<<1|1,ll,rr);
    else if(mid >= rr) query(l,mid,rt<<1,ll,rr);
    else
    {
        query(l, mid, rt<<1, ll,mid);
        query(mid + 1, r, rt<<1|1, mid+1 , rr);
    }
}
int n,m,t;
int a,B,c;
char fuck[5];
int main()
{
    while(~scanf("%d%d%d",&n,&t,&m))
    {
        build(1,n,1);
        while(m--)
        {
            scanf("%s",fuck);
            scanf("%d%d",&a,&B);
            if(a>B) swap(a,B);
            if(fuck[0]=='C')
            {
                scanf("%d",&c);
                change(1,n,1,a,B,c);
            }
            else if(fuck[0]=='P')
            {
                memset(vis,0,sizeof vis);
                query(1,n,1,a,B);
                int cnt=0;
                for(int i=1;i<=t;++i)
                    if(vis[i]) ++cnt;
                cout<<cnt<<endl;
            }
        }
    }
    return 0;
}

query和change函数还可以这么写,比较符合个人习惯,但是跑的比上面慢60ms

void change(int l,int r,int rt,int ll,int rr,int c)
{
    if(ll<=l&&r<=rr)
    {
        b[rt].id=c;
        return ;
    }
    down(l,r,rt);
    int mid=(l+r)>>1;
    if(ll<=mid) change(l,mid,rt<<1,ll,rr,c);
    if(rr>mid) change(mid+1,r,rt<<1|1,ll,rr,c);

}
void query(int l,int r,int rt,int ll,int rr)
{
    if(b[rt].id!=-1)
    {
        vis[b[rt].id]=1;
        return ;
    }
    if(l==r)
    {
        //vis[b[rt].id]=1;
        return;
    }
    int mid=(l+r)>>1;
    if(ll<=mid) query(l,mid,rt<<1,ll,rr);
    if(rr>mid) query(mid+1,r,rt<<1|1,ll,rr);
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值