POJ 3617 best cow line 贪心法

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7793 Accepted: 2423

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD
 
给你一行字符串,全是大写字母,只能采取
 
(1)从该串开头取一个字符加到新字符串的末尾。(2)从该串末尾取一个字符加到新字符串的末尾。 
 
最后使得新串的字典序最小
 
算法:
设元数组为S1,创建另一个倒序数组为S2,然后开始遍历两个数组
如果去当前两个元素中较小者加入到新数组,并对所取的那个数组的下标做加一处理。
假若当前两个元素相等,则用一个for循环不断向下搜索到不相等为止然后对比不相等时谁小,取小的那个数组的元素加入到新数组。
 
#原先wrong answer原因:相等的情况没有处理好,只是随便二选一#
 
 
 
 
#include "stdio.h"
#include "stdlib.h"

main()
{
	int i,j,k,l,n,hold1,hold2;
	char S1[2003]={'\0'},S2[2003]={'\0'},T[2003]={'\0'};
	
	scanf("%d",&n); 
	getchar();
	for(i=0;i
    
    
     
     =0;i-=1,j+=1){
		S2[j]=S1[i];
	}//构造倒序串
	
	for(k=0,i=0,j-=1,l=0;i+l<=j;k+=1){
		if(S1[i]
     
     
      
      S2[l]){
			T[k]=S2[l];
			l+=1;
		}
		else{
			hold1=i,hold2=l;
			for(;S1[hold1]==S2[hold2];hold1+=1,hold2+=1){
				
			}
			if(S1[hold1]
      
      
     
     
    
    
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值