【2019 Multi-University Training Contest 3 】【HDU 6604】Blow up the city(支配树)

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Problem Description

Country A and B are at war. Country A needs to organize transport teams to deliver supplies toward some command center cities.

In order to ensure the delivery works efficiently, all the roads in country A work only one direction. Therefore, map of country A can be regarded as DAG( Directed Acyclic Graph ). Command center cities only received supplies and not send out supplies.

Intelligence agency of country B is credibly informed that there will be two cities carrying out a critical transporting task in country A.

As long as any one of the two cities can not reach a command center city, the mission fails and country B will hold an enormous advantage. Therefore, country B plans to destroy one of the n cities in country A and all the roads directly connected. (If a city carrying out the task is also a command center city, it is possible to destroy the city to make the mission fail)

Now country B has made q hypotheses about the two cities carrying out the critical task.
Calculate the number of plan that makes the mission of country A fail.

Input

The first line contains a integer T (1≤T≤10), denoting the number of test cases.

In each test case, the first line are two integers n,m, denoting the number of cities and roads(1≤n≤100,000,1≤m≤200,000).
Then m lines follow, each with two integers u and v, which means there is a directed road from city u to v (1≤u,v≤n,u≠v).

The next line is a integer q, denoting the number of queries (1≤q≤100,000)
And then q lines follow, each with two integers a and b, which means the two cities carrying out the critical task are a and b (1≤a,b≤n,a≠b).

A city is a command center if and only if there is no road from it (its out degree is zero).

Output

For each query output a line with one integer, means the number of plan that makes the mission of country A fail.

Sample Input

2
8 8
1 2
3 4
3 5
4 6
4 7
5 7
6 8
7 8
2
1 3
6 7
3 2
3 1
3 2
2
1 2
3 1

Sample Output

4
3
2
2
学了支配树之后,这题瞬间就有思路了,算是属于知识垄断题吧
代码:

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
#include<vector>
#define ll long long
#define maxx  100005
using namespace std;
int n,m;
vector<int>g[maxx];
int ind[maxx];
int order[maxx],cnt;
queue<int>q ;
void topo()
{
    for(int i=1;i<=n;i++)if(!ind[i])q.push(i);
    cnt=0;
    while(q.size())
    {
        int u=q.front();q.pop();
        order[++cnt]=u;
        for(int i=0;i<g[u].size();i++)
        {
            int v=g[u][i];
            if(--ind[v]==0)q.push(v);
        }
    }
}
int f[maxx][20],N;
int dep[maxx];
void update(int x,int fa)
{
    f[x][0]=fa;
    for(int i=1;i<=N;i++)
        f[x][i]=f[f[x][i-1]][i-1];
}
inline int lca(int x,int y)
{
    if(dep[x]>dep[y])swap(x,y);
    for(int i=N;i>=0;i--)
        if(dep[f[y][i]]>=dep[x])y=f[y][i];
    if(x==y)return x;
    for(int i=N;i>=0;i--)
        if(f[x][i]!=f[y][i])x=f[x][i],y=f[y][i];
    return f[x][0];
}
void buildTree()
{
    dep[n+1]=1;
    update(n+1,0);
    for(int i=n;i>=1;i--)
    {
        int u=order[i];
        if(g[u].size()==0)
        {
            dep[u]=2;
            update(u,n+1);
            continue;
        }
        int v=g[u][0];
        for(int j=1;j<g[u].size();j++)
            v=lca(v,g[u][j]);
        dep[u]=dep[v]+1;
        update(u,v);
    }
}
void init()
{
    for(int i=1;i<=n;i++)g[i].clear();
    N=ceil(log2(n));
}
int main()
{
    int t;cin>>t;
    int x,y;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init();
        while(m--)
        {
            scanf("%d%d",&x,&y);
            g[x].push_back(y);
            ind[y]++;
        }
        topo();
        buildTree();
        //for(int i=1;i<=n;i++)cout<<i<<" "<<f[i][0]<<endl;
        int q;cin>>q;
        while(q--)
        {
            scanf("%d%d",&x,&y);
            int k=lca(x,y);
            if(k==n+1)printf("%d\n",dep[x]+dep[y]-2);
            else printf("%d\n",dep[x]+dep[y]-dep[k]-1);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值