HDOJ1208 记忆化搜索水题

Pascal’s Travels

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2575 Accepted Submission(s): 1221

Problem Description
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

Figure 1

Figure 2

Input
The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output
The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

Sample Input
4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output
3
0
7

Hint
Hint

Brute force methods examining every path will likely exceed the allotted time limit.
64-bit integer values are available as “__int64” values using the Visual C/C++ or “long long” values
using GNU C/C++ or “int64” values using Free Pascal compilers.

Source
Mid-Central USA 2005

Recommend
mcqsmall | We have carefully selected several similar problems for you: 1074 1072 1180 1195 1045

写了一个非常标准的记忆化搜索程序

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn = 40;
int n,i,j,k,a[maxn][maxn];
long long  dp[maxn][maxn];

void init(){
   char str[50];
   getchar();
   for (i=1; i<=n; i++){
     gets(str);
     for (j=1; j<=n; j++) a[i][j] = str[j-1] - '0';
   }

   for (i=1; i<=n; i++)
     for (j=1; j<=n; j++)
        dp[i][j] = 0;
   dp[n][n] = 1;
}

long long dfs(int x, int y){
   if (dp[x][y]) return dp[x][y];
   if (a[x][y]==0) return 0;
   if (x+a[x][y]<=n) dp[x][y] += dfs(x+a[x][y],y);
   if (y+a[x][y]<=n) dp[x][y] += dfs(x,a[x][y]+y);
   return dp[x][y];
}

int main(){
    while (scanf("%d",&n)!=EOF) {
          if (n==-1) break;
          init();
          cout << dfs(1,1) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值