HDOJ1595 find the longest of the shortest 最短路+枚举

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3668 Accepted Submission(s): 1362

Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input
5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output
11
13
27

Author
ailyanlu

Source
HDU 2007-Spring Programming Contest - Warm Up (1)

Recommend
8600 | We have carefully selected several similar problems for you: 1599 1596 1598 1597 1301

首先求一遍最短路,这是不堵塞的情况。然后枚举最短路径里的每条边不通的情况,找其中路径最长的。
不知道怎么回事,一直超时。。可能人品太差????
把dijstra写法改了改才过,用时也是蛮多的。。。。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;

const int inf = 1<<25;
const int maxn = 1005;
int i,j,k,n,m,max_dis,tot,A,B,V;
int dis[maxn],a[maxn][maxn],pre[maxn];
bool vis[maxn];

void dijstra(int f){
    int s,tmp,d;
    for (i=1; i<=n; i++) {
        vis[i] = 0;
        dis[i] = a[1][i];
    }
    vis[1] = 1; s=1;

    for (j = 1; j<n; j++) {
        d = inf;
        for (i=1; i<=n; i++) if (!vis[i] && d>dis[i]) {
            s = i;
            d = dis[i];
        }
        vis[s] = 1;
        for (i=1; i<=n; i++) if (!vis[i] && dis[i]>dis[s]+a[s][i]) {
             dis[i] = dis[s] + a[s][i];
             if (f) pre[i] = s;
        }
    }
}

int main(){
    while (scanf("%d%d",&n,&m)!=EOF){
        for (i=1; i<=n; i++) {
            for (j=1; j<=n; j++) a[i][j] = inf;
            a[i][i]=0;
            pre[i] = 1;
        }

        for (i=1; i<=m; i++) {
            scanf("%d%d%d",&A,&B,&V);
            if (a[A][B]>V) a[A][B] = a[B][A] = V;
        }

        tot = 0;
        dijstra(1);
        max_dis = dis[n];

        for (k=n; k!=1; k=pre[k]) {
            int temp = a[pre[k]][k];
            a[k][pre[k]] = a[pre[k]][k] = inf;
            dijstra(0);
            max_dis = max(max_dis,dis[n]);
            a[k][pre[k]] = a[pre[k]][k] = temp;
        }

        printf("%d\n",max_dis);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值