Falling Leaves
Description Figure 1 Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem. A binary tree of letters may be one of two things:
In the graphical representation of a binary tree of letters:
A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y. The preorder traversal of a tree of letters satisfies the defining properties:
The preorder traversal of the tree in Figure 1 is KGCBDHQMPY. A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies: The root's data comes later in the alphabet than all the data in the nodes in the left subtree. The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree. The problem: Consider the following sequence of operations on a binary search tree of letters Remove the leaves and list the data removed Repeat this procedure until the tree is empty Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree by removing the leaves with data BDHPY CM GQ K Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree. Input
The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.
The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*'). The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input. Output
For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.
Sample Input BDHPY CM GQ K * AC B $ Sample Output KGCBDHQMPY BAC Source |
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 30;
struct SBT{
int left,right;
char c;
}tree[maxn];
int root,tot,st;
char s[maxn][maxn];
void add(int x, char ch){
if (ch<tree[x].c){
if (tree[x].left == 0){
tree[tot].c = ch;
tree[x].left = tot++;
}
else add(tree[x].left,ch);
}
else {
if (tree[x].right == 0){
tree[tot].c = ch;
tree[x].right = tot++;
}
else add(tree[x].right,ch);
}
}
void Print(int x){
printf("%c",tree[x].c);
if (tree[x].left) Print(tree[x].left);
if (tree[x].right) Print(tree[x].right);
}
int main(){
st = 0;
while (scanf("%s",s[st++])!=EOF){
if (s[st-1][0]=='*' || s[st-1][0]=='$') {
root = tot = 0;
memset(tree,0,sizeof(tree));
tree[tot++].c = s[st-2][0];
for (int i=st-3; i>=0; i--) {
for (int j=0; j<strlen(s[i]); j++) add(root,s[i][j]);
}
Print(root);
if (s[st-1][0]=='$') break;
st = 0;
printf("\n");
}
}
return 0;
}