HDOJ1237 逆波兰表达式

简单计算器

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22629 Accepted Submission(s): 8185

Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output
3.00
13.36

Source
浙大计算机研究生复试上机考试-2006年

Recommend
JGShining | We have carefully selected several similar problems for you: 1230 1235 1234 1236 1229

分析:比较水,用到了数据结构栈,因为我比较懒,就用了STL

#include <cstring>
#include <cmath>
#include <cstdio>
#include <stack>
using namespace std;

stack<double>a;
double x,tmp;
char ch,op;

int main(){
    while (scanf("%lf",&x)!=EOF){
         while (!a.empty()) a.pop();
         ch = getchar();
         if (x==0 && ch=='\n') break;

         scanf("%c",&op);
         a.push(x);
         while (scanf("%lf",&x)!=EOF){
             if (op=='*'){
                tmp = a.top();
                a.pop();
                a.push(tmp*x);
             }
             else if (op=='/'){
                tmp = a.top();
                a.pop();
                a.push(tmp/x);
             }
             else if (op=='-'){
                a.push(-x);
             }
             else a.push(x);

             ch = getchar();
             if (ch=='\n') break;
             scanf("%c",&op);
             ch = getchar();
         }

         double ans = 0;
         while (!a.empty()) {ans += a.top(); a.pop();}
         printf("%.2lf\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值