HDOJ 2669 扩展欧几里得

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7534    Accepted Submission(s): 3200


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry 7 -3
 

Author
yifenfei
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2668  2674  2671  2670  2672 

分析:
裸的扩展欧几里得运用,注意题目要求的是x为正整数。
如果gcd(a,b)!=1 输出sorry
否则 如果 x<0, x +=b, y-=a.
x = x0 + b/gcd(a,b)*t , y= y0 -a/gcd(a,b)*t.

代码如下:
#include <cstdio>
using namespace std;

typedef long long ll;
ll a,b,x,y;
ll gcd;

ll extend_gcd(ll a, ll b, ll &x , ll &y){
    if (b==0) {
        x=1; y=0;
        return a;
    }

    ll r = extend_gcd(b,a%b,y,x);
    y -= x*(a/b);
    return r;
}

int main(){
    while (scanf("%lld %lld",&a,&b)!=EOF){
         gcd = extend_gcd(a,b,x,y);
         if (gcd!=1) printf("sorry\n");
         else {
            x %= b;
            if (x<=0) {x+=b; y-=a;}
            printf("%lld %lld\n",x,y);
         }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值