1011 World Cup Betting (20)

题目

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.13.02.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

翻译

随着2010年世界杯的来临,当最厉害的球员来自最好的球队在南非,全世界的球迷都很开心。相似的是人们开始赌球了。中国足球赌彩·提供了一个三次胜利的游戏。规则很简单:原道每一次概率最好的球队。
公式:(4.13.02.5*65%-1)*2 = 37.98

要点

一定要注意sum是从1.0开始的
应该选择double变量

代码

#include<iostream>
#include<cstdio>
using namespace std;
char s[3]={'W','T','L'};
int main()
{
	double sum=1.0;
	double temp,a;
	for(int j=0;j<3;j++)
	{
		temp=0.0;
		int b;
		for(int i=0;i<3;i++)
		{
			cin>>a;
			if(a>temp) 
			{
				temp=a;
				b=i;
			}
			
		}
		sum*=temp;
		cout<<s[b]<<" ";
	
	}
	sum=(sum*0.65-1)*2;
	printf("%.2f",sum);
	return 0;
}
```cpp


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值