Almost Union-Find(带删除并查集模板)

I hope you know the beautiful Union-Find structure. In this problem, you’re to implement something
similar, but not identical.
The data structure you need to write is also a collection of disjoint sets, supporting 3 operations:
1 p q Union the sets containing p and q. If p and q are already in the same set,
ignore this command.
2 p q Move p to the set containing q. If p and q are already in the same set,
ignore this command.
3 p Return the number of elements and the sum of elements in the set containing
p.
Initially, the collection contains n sets: {1}, {2}, {3}, . . . , {n}.
Input
There are several test cases. Each test case begins with a line containing two integers n and m
(1 ≤ n, m ≤ 100, 000), the number of integers, and the number of commands. Each of the next m lines
contains a command. For every operation, 1 ≤ p, q ≤ n. The input is terminated by end-of-file (EOF).
Output
For each type-3 command, output 2 integers: the number of elements and the sum of elements.
Explanation
Initially: {1}, {2}, {3}, {4}, {5}
Collection after operation 1 1 2: {1,2}, {3}, {4}, {5}
Collection after operation 2 3 4: {1,2}, {3,4}, {5} (we omit the empty set that is produced when
taking out 3 from {3})
Collection after operation 1 3 5: {1,2}, {3,4,5}
Collection after operation 2 4 1: {1,2,4}, {3,5}
Sample Input
5 7
1 1 2
2 3 4
1 3 5
3 4
2 4 1
3 4
3 3
Sample Output
3 12
3 7
2 8

题意:有n个数,刚开始每个数都是一个单独的集合里,给定下列三种操作

1 p q :将p 和 q 合并在一个集合里

2 p q :将p 放在 q所在的集合里

3 p : 输出p 所在的集合的元素个数和元素的和。
主要问题就是操作二:如果直接令p的父亲等于q的祖宗,那么与p相连的其他值就会跟着发生改变,因此这道题引进一个外壳数组使他们外壳相连,这样p的父亲值并不改变,让其外壳值等于q的祖宗即可
看代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAX=1e6+10;
int n,m,a,b,c,fx,fy;
int ke[MAX],cnt[MAX],f[MAX],sum[MAX];
void init() {
	for(int i=1; i<=n; i++) {
		sum[i]=f[i]=ke[i]=i;
		cnt[i]=1;
	}
}
int getf(int x) {
	return f[x]==x?x:f[x]=getf(f[x]);
}
void move() {
	cnt[fx]--;
	sum[fx]-=b;
	ke[b]=fy;//*****重点:只把外壳值改变,并不改变b的父亲值 
	sum[fy]+=b;
	cnt[fy]++;
}

void solve() {
	while(~scanf("%d %d",&n,&m)) {
		init();
		for(int i=1; i<=m; i++) {
			scanf("%d",&a);
			if(a==3) {
				scanf("%d",&b);
				fx=getf(ke[b]);
				printf("%d %d\n",cnt[fx],sum[fx]);
				continue;
			}
			scanf("%d %d",&b,&c);
			fx=getf(ke[b]);
			fy=getf(ke[c]);
			if(fx==fy)
				continue;
			if(a==1) {
				f[fx]=fy;
				cnt[fy]+=cnt[fx];
				sum[fy]+=sum[fx];
			}
			if(a==2)
				move();
		}
	}
}
int main() {
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值