rpm安装openssl-devel

Linux运维 专栏收录该内容
8 篇文章 0 订阅

由于有时候所用环境不能上外网,不能通过yum来安装解决依赖包的问题,但是openssl-devel的安装有很多依赖关系,有时候甚至装着装着就忘了装了哪些还要装哪些了。。。现在把我的安装过程整理如下:

CentOS 6.3, 64bit.

已经安装openssl-1.0.1e-48.el6

准备安装 openssl-devel-1.0.1e-48.el6.x86_64.rpm

openssl-devel下载地址: https://centos.pkgs.org/6/centos-x86_64/openssl-devel-1.0.1e-48.el6.x86_64.rpm.html

其他所需所需安装包下载地址: ftp://mirror.switch.ch/mirror/centos/6/os/x86_64/Packages/

通过rpm -ivh或者rpm -Uvh依次安装:

keyutils-1.4-5.el6.x86_64.rpm

keyutils-libs-1.4-5.el6.x86_64.rpm

keyutils-libs-devel-1.4-5.el6.x86_64.rpm

krb5-devel-1.10.3-57.el6.x86_64.rpm

krb5-libs-1.10.3-57.el6.x86_64.rpm

krb5-workstation-1.10.3-57.el6.x86_64.rpm

libss-1.41.12-22.el6.x86_64.rpm

libss-devel-1.41.12-22.el6.x86_64.rpm

e2fsprogs-1.41.12-22.el6.x86_64.rpm

e2fsprogs-devel-1.41.12-22.el6.x86_64.rpm

e2fsprogs-libs-1.41.12-22.el6.x86_64.rpm

libselinux-2.0.94-7.el6.x86_64.rpm

libselinux-devel-2.0.94-7.el6.x86_64.rpm

libselinux-utils-2.0.94-7.el6.x86_64.rpm

krb5-devel-1.10.3-57.el6.x86_64.rpm

zlib-1.2.3-29.el6.x86_64.rpm

zlib-devel-1.2.3-29.el6.x86_64.rpm

openssl-devel-1.0.1e-48.el6.x86_64.rpm

 

安装过程中,有些安装包相互依赖,可以一起安装,例如:

rpm -Uvhkrb5-workstation-1.10.3-57.el6.x86_64.rpm krb5-libs-1.10.3-57.el6.x86_64.rpm 


  • 1
    点赞
  • 0
    评论
  • 4
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值