uva1391 - Astronauts 2-SAT

The Bandulu Space Agency (BSA) has plans for the following three space missions:

  • Mission A: Landing on Ganymede, the largest moon of Jupiter.
  • Mission B: Landing on Callisto, the second largest moon of Jupiter.
  • Mission C: Landing on Titan, the largest moon of Saturn.

Your task is to assign a crew for each mission. BSA has trained a number of excellent astronauts; everyone of them can be assigned to any mission. However, if two astronauts hate each other, then it is not wise to put them on the same mission. Furthermore, Mission A is clearly more prestigious than Mission B; who would like to go to the second largest moon if there is also a mission to the largest one? Therefore, the assignments have to be done in such a way that only young, inexperienced astronauts go to Mission B, and only senior astronauts are assigned to Mission A. An astronaut is considered young if their age is less than the average age of the astronauts and an astronaut is senior if their age is at least the averageage. Every astronaut can be assigned to Mission C, regardless of their age (but you must not assign two astronauts to the same mission if they hate each other).

Input 

The input contains several blocks of test cases. Each case begins with a line containing two integers 1$ \le$n$ \le$100000 and 1$ \le$m$ \le$100000. The number n is the number of astronauts. The next n lines specify the age of the n astronauts; each line contains a single integer number between 0 and 200. The next m lines contains two integers each, separated by a space. A line containing i and j (1$ \le$i, j$ \le$n) means that the i-th astronaut and the j-th astronaut hate each other.

The input is terminated by a block with n = m = 0.

Output 

For each test case, you have to output n lines, each containing a single letter. This letter is either `A', `B', or `C'. The i-th line describes which mission the i-th astronaut is assigned to. Astronauts that hate each other should not be assigned to the same mission, only young astronauts should be assigned to Mission B and only senior astronauts should be assigned to Mission A. If there is no such assignment, then output the single line `No solution.' (without quotes).

Sample Input 

16 20
21
22
23
24
25
26
27
28
101
102
103
104
105
106
107
108
1 2
3 4
5 6 
7 8
9 10
11 12
13 14
15 16
1 10
2 9
3 12
4 11
5 14
6 13 
7 16
8 15
1 12
1 13
3 16
6 15
0 0

Sample Output 

B
C
C
B
C
B
C
B
A
C
C
A
C
A
C
A

  有A,B,C 3个任务分配给N个人,每个人分配一个,年龄大于等于平均年龄的只能分配A或C,否则只能分配B或C。有M对人相互讨厌,相互讨厌的人不能分配到一样的任务。

  每个人只有2种选择,这就变成了一个2-SAT问题。把年龄大于等于平均年龄的人设为第1类,年龄小于平均年龄的设为第2类。第1类设分配A为真,分配C为假,第2类人分配B为真,C为假。相互讨厌的两个人u,v如果属于同一类,那么就要增加两次边,u真或v真,u假或v假,如果两个人不是同一类,就只需要增加一次边,u真或v真。

  2-SAT在搜索过程中记录选择情况,最后再根据每个人的类型输出对应的答案。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
#define INF 0x3f3f3f3f
#define eps 1e-9
#define MAXN 100010
#define MAXM 2000010
#define MAXNODE 105
#define MOD 100000
#define SIGMA_SIZE 4
typedef long long LL;
using namespace std;
int T,N,M,sum,age[MAXN],ans[MAXN],type[MAXN];
struct TwoSAT{
    int n,c,S[MAXN*2];
    bool mark[MAXN*2];
    vector<int> G[MAXN*2];
    void init(int n){
        this->n=n;
        for(int i=0;i<n*2;i++) G[i].clear();
        memset(mark,0,sizeof(mark));
    }
    bool dfs(int x){
        if(mark[x^1]) return false;
        if(mark[x]) return true;
        mark[x]=true;
        S[c++]=x;
        int L=G[x].size();
        for(int i=0;i<L;i++) if(!dfs(G[x][i])) return false;
        return true;
    }
    void add_clause(int x,int xval,int y,int yval){
        x=x*2+xval;
        y=y*2+yval;
        G[x^1].push_back(y);
        G[y^1].push_back(x);
    }
    bool solve(){
        for(int i=0;i<n*2;i+=2) if(!mark[i]&&!mark[i+1]){
            c=0;
            if(!dfs(i)){
                while(c>0) mark[S[--c]]=false;
                if(!dfs(i+1)) return false;
            }
            while(c>0) ans[S[--c]>>1]=S[c]%2;
        }
        return true;
    }
}solver;

int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d%d",&N,&M)!=EOF&&(N||M)){
        sum=0;
        for(int i=0;i<N;i++){
            scanf("%d",&age[i]);
            sum+=age[i];
        }
        for(int i=0;i<N;i++){
            if(age[i]*N>=sum) type[i]=1;
            else type[i]=2;
        }
        solver.init(N);
        int u,v;
        while(M--){
            scanf("%d%d",&u,&v);
            u--;
            v--;
            if(type[u]==type[v]){
                solver.add_clause(u,1,v,1);
                solver.add_clause(u,0,v,0);
            }
            else solver.add_clause(u,1,v,1);
        }
        if(!solver.solve()) printf("No solution.\n");
        else for(int i=0;i<N;i++){
            if(!ans[i]) printf("C\n");
            else if(type[i]==1) printf("A\n");
            else printf("B\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值