uva1347 - Tour DP

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xiyi > . John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinctx -coordinates.

Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input 

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output 

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result.


Note: An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input 

3 
1 1
2 3
3 1
4 
1 1 
2 3
3 1
4 2

Sample Output 

6.47
7.89

  有N个点,从1出发到N再返回1,除了1和N只经过其他点1次,求最短距离。

  相当于两个人从1出发走两条不相交的路到N(x小的肯定比x大的先经过),dp[i][j]表示两个人分别在i,j(i>j),并且从1-i的所有点都经过的最短距离。dp[1][1]初始化为0,其它INF,对于j<i-1,那肯定是从dp[i-1][j],i-1到i走一步递推来,对于j=i-1,那么可以从1-j的任意一点到i。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
using namespace std;
typedef long long LL;
typedef pair<LL,LL> pii;

const int MAXN=1010;
const LL MAXM=2600;
const double INF=999999999999.0;
const LL MOD=1000000009;

int N;
double dp[MAXN][MAXN],dist[MAXN][MAXN],x[MAXN],y[MAXN];

int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d",&N)!=EOF){
        for(int i=1;i<=N;i++) scanf("%lf%lf",&x[i],&y[i]);
        for(int i=1;i<=N;i++)
            for(int j=i+1;j<=N;j++) dist[i][j]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
        for(int i=0;i<=N;i++)
            for(int j=0;j<=N;j++) dp[i][j]=INF;
        dp[1][1]=0;
        for(int i=2;i<=N;i++){
            for(int j=1;j<i-1;j++){
                if(dp[i-1][j]!=INF) dp[i][j]=min(dp[i][j],dp[i-1][j]+dist[i-1][i]);
            }
            for(int j=1;j<i;j++){
                if(dp[i-1][j]!=INF) dp[i][i-1]=min(dp[i][i-1],dp[i-1][j]+dist[j][i]);
            }
        }
        double ans=INF;
        for(int i=1;i<N;i++) ans=min(ans,dp[N][i]+dist[i][N]);
        printf("%.2lf\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值