HDOJ1032 The 3n+1 Problem(趣味数字——"角谷猜想"实现)

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40189    Accepted Submission(s): 14697


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 

Sample Input
  
  
1 10 100 200 201 210 900 1000
 

Sample Output
  
  
1 10 20 100 200 125 201 210 89 900 1000 174
 

Source
UVA

【分析】"角谷猜想"实现。

题意:输入两个数i和j,对于[i, j]上上的每个数x,若x是奇数,则x=3*x+1; 若x是偶数,则x=x/2,直到x为1为止。求出此闭区间上包括x和1在内的最大循环圈的长度(如给出的22:22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1,循环圈长度为16)。

        需要注意i和j的大小关系并未指定,应该分i<=j 和 i>j 两种情况讨论。最后输出i、j和最大循环圈长度。

#include <stdio.h>
typedef long long ll;
ll m,n;
void swap(ll *a,ll *b)
{
	ll t;
	t=*a;
	*a=*b;
	*b=t;
}
int main()
{
	ll i,tm,tn;
	ll len,maxl,temp;
	while(scanf("%lld %lld",&m,&n)!=EOF)
	{
		tm=m;       //用tm和tn保存输入的m和n,便于后续操作 
		tn=n;
		if(m>n)
			swap(&m,&n);
		maxl=0;
		for(i=m;i<=n;i++)
		{
			temp=i;
			len=1;
			while(temp!=1)
			{
				len++;
				if(temp%2==0)
					temp/=2;
				else
					temp=3*temp+1;
			}
			if(len>maxl)
				maxl=len;
		}
		if(tm>tn)
			printf("%lld %lld %lld\n",n,m,maxl);
		else
			printf("%lld %lld %lld\n",m,n,maxl);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值