HDOJ1711. Number Sequence(KMP模板题)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34027    Accepted Submission(s): 14181


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output

6
-1

【分析】KMP 模板题

        题意:在a数组中,是否可找到一个子数组与b数组完全相同。若可以,输出所求子数组的最小下标(从1开始),否则输出"-1"。

#include <stdio.h>
#define maxN 1000005
#define maxM 10005
int T,N,M;
int a[maxN];
int b[maxM],next[maxM];
void getNext(int *b,int *next,int m)
{
	int i,j;
	i=0,j=-1;
	next[i]=j;
	while(i<m)
	{
		if(j==-1 || b[i]==b[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
void find(int *a,int n,int *b,int m)
{
	int i,j;
	int ret;
	i=j=0;
	ret=-1;
	getNext(b,next,m);
	while(i<n)
	{
		if(j==-1 || a[i]==b[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
		if(j==m)
		{
			ret=i-j+1;
			break;
		}
	}
	printf("%d\n",ret);
}
int main()
{
	int i;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&N,&M);
		for(i=0;i<N;i++)
			scanf("%d",&a[i]);
		for(i=0;i<M;i++)
			scanf("%d",&b[i]);
		find(a,N,b,M);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值