HDOJ1003. Max Sum(DP——最大连续子序列和)

22 篇文章 2 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 276300    Accepted Submission(s): 65616


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


【分析】DP——最大连续子序列和问题

#include <stdio.h>
#define maxn 100005
#define INF 1<<30
int T,N;
int a[maxn]; 
int ncase=1;
int main()
{
	int i;
	//cursum-当前子序列和 maxsum-所求最大子序列和 
	int cursum,maxsum; 
	//start.end-子序列起点与终点 temp-当前起始位置 
	int start,end,temp;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		for(i=0;i<N;i++)
			scanf("%d",&a[i]);
		//初始化 
		maxsum=-INF,cursum=0;
		start=temp=0;
		for(i=0;i<N;i++)
		{
			//若当前子序列和<0
			//则说明i前面的序列可舍弃,从a[i]开始求解
			//temp标记新的起始位置 
			if(cursum<0)
			{
				cursum=a[i];
				temp=i;
			}
			//否则在cursum的基础上+a[i],向后寻找 
			else
				cursum+=a[i];
			//更新最大值及子序列起点&终点 
			if(cursum>maxsum)
			{
				maxsum=cursum;
				start=temp+1;
				end=i+1;
			}
		}
		printf("Case %d:\n",ncase++);
		printf("%d %d %d\n",maxsum,start,end);
		if(T>0)
			printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值