2016亚洲区域赛现场赛北京赛区f题

Problem F. What a Simple Research
Description
Peking University Student Folk Music Band has a history of more than 90 years. They play Chinese traditional music by Chinese traditional instruments, such as Pipa, Erhu and Guzheng, etc. Doctor Li is a member of that band, and also a former ACMer. Now he is doing some research on Chinese ancient music. Many Chinese ancient music has only five kinds of tones, which can be denoted by ‘C’,’D’,’E’,’G’, and ‘A’. Given a piece of music score, Li wants to do some simple statistics.
Input
There are no more than 20 test cases.
In each test case:
The first line contains two integers n and m (2<= n,m <= 20), indicating that a piece of music score is represented by an n×m matrix of tones. Only ‘C’,’D’,’E’,’G’ and ‘A’ can appear in the matrix.
Then the n×m matrix follows.
The input ends with a line of “0 0”.
Output
For each test case:
For each kind of tone shown in the matrix, calculate the appearing times of it, and print the result in descending order according to the appearing times. If more than one kind of tones has the same appearing times, print them in the lexicographical order.
Sample Input
4 5
AGCDE
AGDDE
DDDDD
EEEEE
2 4
GADC
CDEE
0 0
Sample Output
D 8 E 7 A 2 G 2 C 1
C 2 D 2 E 2 A 1 G 1
题意:给你一个字符矩阵,里面只含有A,C,D,E,G五种字符,问你把出现过的字符次数从大到小排出来,若次数相同,则按照acs码从大到小。

解题思路:签到题,模拟即可,注意没有出现的字符不要输出来就行

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
    int value;
    char ch;
}Node[10];
bool cmp(node n1,node n2)
{
    if(n1.value == n2.value) return n1.ch < n2.ch;
    else return n1.value > n2.value;
}
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n == 0&&m == 0) break;
        char x;
        Node[1].value = 0;
        Node[1].ch = 'A';
        Node[2].value = 0;
        Node[2].ch = 'C';
        Node[3].value = 0;
        Node[3].ch = 'D';
        Node[4].value = 0;
        Node[4].ch = 'E';
        Node[5].value = 0;
        Node[5].ch = 'G';
        getchar();
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                scanf("%c",&x);
                for(int k = 1; k <= 5; k++)
                {
                    if(x == Node[k].ch)
                    {
                        Node[k].value++;
                        break;
                    }
                }
            }
            getchar();
        }
        sort(Node + 1,Node + 6,cmp);
        bool flag = true;
        for(int i = 1; i <= 5; i++)
        {
            if(Node[i].value != 0)
            {
                if(flag)
                {
                    printf("%c %d",Node[i].ch,Node[i].value);
                    flag = false;
                }
                else printf(" %c %d",Node[i].ch,Node[i].value);
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值