POJ 3366//基本的字符串处理!

Deli Deli
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3654 Accepted: 2059

Description

Mrs. Deli is running the delicatessen store "Deli Deli". Last year Mrs. Deli has decided to expand her business and build up an online store. She has hired a programmer who has implemented the online store.

Recently some of her new online customers complained about the electronic bills. The programmer had forgotten to use the plural form in case that an item is purchased multiple times. Unfortunaly the programmer of Mrs. Deli is on holiday and now it is your task to implement this feature for Mrs. Deli. Here is a description how to make the plural form:

  1. If the word is in the list of irregular words replace it with the given plural.
  2. Else if the word ends in a consonant followed by "y", replace "y" with "ies".
  3. Else if the word ends in "o", "s", "ch", "sh" or "x", append "es" to the word.
  4. Else append "s" to the word.

Input

The first line of the input file consists of two integers L and N (0 ≤ L ≤ 201 ≤ N ≤ 100). The following L lines contain the description of the irregular words and their plural form. Each line consists of two words separated by a space character, where the first word is the singular, the second word the plural form of some irregular word. After the list of irregular words, the following N lines contain one word each, which you have to make plural. You may assume that each word consists of at most 20 lowercase letters from the English alphabet ('a' to 'z').

Output

Print N lines of output, where the ith line is the plural form of the ith input word.

Sample Input

3 7
rice rice
spaghetti spaghetti
octopus octopi
rice
lobster
spaghetti
strawberry
octopus
peach
turkey

Sample Output

rice
lobsters
spaghetti
strawberries
octopi
peaches
turkeys

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

/*题意:把单词的单数变成复数,规则是:特殊的给出来直接输出就行,
不规则变化按照所说的规则变化
就是简单的字符串处理
*/
#include <iostream>
#include<string>
using namespace std;
struct {
    string m;
    string  n;
} node[100];
int main() {
    int a,b,i,flag;
    string m[100],line;
    string::size_type len;
    cin >> a>> b;
    for(i=0; i<a; i++)
        cin >> node[i].m >> node[i].n;
    while(b--) {
        flag=0;
        cin>> line ;
        for(i=0; i<a; i++)
            if(node[i].m==line) {
                flag=1;
                cout<< node[i].n << endl;
            }
        if(!flag) {
            len=line.size();
            if(line[len-1]=='x'||line[len-1]=='o'||line[len-1]=='s')  line=line+"es";
            else if(line[len-1]=='y'&&line[len-2]!='a'&&line[len-2]!='e'&&line[len-2]!='i'&&line[len-2]!='o'&&line[len-2]!='u') {
                line[len-1]='i';
                line=line+"es";
            } else if(line[len-1]=='h') {
                if(line[len-2]=='s'||line[len-2]=='c')
                    line=line+"es";
            } else line=line+"s";
            cout << line << endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值