SPF 题解

描述

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.

输入

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

输出

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

样例输入

 

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0
 

样例输出

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets


题目意思是找去掉割点之后,剩余几个联通块。

找割点就用targan算法解决,这里还需要得到去掉割点后有几个连通块,那么,对于某个点u如果它之后还没访问的点在去掉u之后能到的最小的点大于等于这个点被访问到的那么去掉割点之后它所在的部分就是一个新的联通块(去掉割点跟别的其他部分都不连通了),这里用map记录,多组数据记得初始化。

代码

#include<bits/stdc++.h>

using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 100010, MOD = 998244353;
int n, m;
int dfn[N], low[N], cnt = 1;
map<int, int> mp;
int h[N], e[N], ne[N], idx;
void add(int a, int b) {
	e[idx] = b, ne[idx] = h[a], h[a] = idx ++;
}

void dfs(int u) {
	dfn[u] = low[u] = cnt ++;
	int num = 0;
	for(int i = h[u];~i;i = ne[i]) {
		int j = e[i];
		if(!dfn[j]) {
			num ++;
			dfs(j);
			low[u] = min(low[u], low[j]);
			if(u == 1 && num > 1 || u != 1 && low[j] >= dfn[u])
				mp[u] ++;
		}else low[u] = min(low[u], dfn[j]);
	}
}

int main() { 
	ios::sync_with_stdio(false);
	cin.tie(0), cout.tie(0);
	int cas = 0;
	while(cin >> n, n) {
		cas ++;
		memset(h, -1, sizeof h);
		memset(dfn, 0, sizeof dfn);
		memset(low, 0, sizeof low);
		mp.clear();
		idx = 0, cnt = 1;

		cin >> m;
		add(n, m), add(m, n);
		while(cin >> n, n) {
			cin >> m;
			add(n, m), add(m, n);
		}

		dfs(1);
		if(cas > 1) cout << '\n';
		cout << "Network #" << cas << '\n';
		if(mp.size()){
			for(auto it : mp) {
				cout << "  SPF node " << it.first << " leaves " << it.second + 1 << " subnets\n";
			}
		}else cout << "  No SPF nodes\n";
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值