北邮09复试模拟problem c

寻找第K小的数 Submit: 1621    Accepted:702 Time Limit: 1000MS  Memory Limit: 65536K

Description
给你n个完全不相同整数(n<=300),每一个数都大于0并且小于1000,请找出第k小的数。


Input
输入包括两行,第一行用空格隔开的两个数 n和k;第二行有n个不行同的数;


Output
输出第k小的数字;


Sample Input

5 3
3 2 5 4 1


Sample Output

3


Source

 import java.util.*;
public class proc {
 public static void main(String[] args){
  ArrayList a=new ArrayList();
  Scanner cin=new Scanner(System.in);
  while(cin.hasNextInt()){
   int n=cin.nextInt();
   int k=cin.nextInt();
   for(int i=0;i<n;i++){
    a.add(i,cin.nextInt());
   }
   Collections.sort(a);
   System.out.println(a.get(k-1));

a.clear();
  }
 }
}

只是能ac~当然里面好多使用不得当的地方~姑且不考虑了~

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值