HDU-Red and Black

HDU-Red and Black

点击打开链接

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)


Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output
45
59
6
13

有一个矩形的房间,覆盖着方砖。每个瓷砖都是红色或黑色。一个男人站在黑色的瓦片上。从瓦片,他可以移动到四个相邻的瓷砖之一。但他不能在红砖上移动,他只能在黑砖上移动。
编写一个程序来计算他可以通过重复上述移动来达到的黑色瓦片的数量。

输入
输入由多个数据集组成。数据集以包含两个正整数W和H的行开始; W和H分别是x和y方向上的瓦片数。 W和H不超过20。
数据集中有更多的行,每行都包含W个字符。每个字符代表瓦片的颜色如下。
'.'一块黑色瓷砖
'#' - 一个红色的瓷砖
'@' - 黑色瓦片上的人(在数据集中恰好出现一次)

输出
对于每个数据集,您的程序应输出一行,其中包含可以从初始磁贴(包括其自身)到达的磁贴数。

样品输入
6 9
....#。
.....#
......
......
......
......
......
#@#...
#..#。
11 9
#.........
。########。
###......。
######。
##.. @#,#。
。#######。
#.......#。
。#########。
...........
11 6
..#..#..#..
..#..#..#..
..#..#.. ###
..#..#..#@。
..#..#..#..
..#..#..#..
7 7
..##..
..##..
###。###
... @ ...
###。###
..##..
..##..
0 0

样品输出
45
59
6
13


#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 22;//限定一个变量不允许被改变   
typedef long long LL;  
char a[MAX][MAX];   
int n,m,v[MAX][MAX],ans;
int fx[4]={0,0,-1,1},fy[4]={-1,1,0,0};  
void dfs(int x,int y)  
{  
    v[x][y]=1, ans++;//标记一下,代表走过了  
    for(int i=0;i<4;i++)  
    {  
        int xx=x+fx[i],yy=y+fy[i];//表示朝向不同的方向走   
        if(xx >=0 && yy>=0 &&xx<n&&yy<m&&!v[xx][yy]&&a[xx][yy]=='.') // 判断是否出界, 是否已经搜索过, 是否为油田   
            // 判断是否越界,x,y 的下界都是 0 ,上界分别 是 n,m  
        dfs(xx,yy);  
    }   
}   
int main()
{
	
    while(~scanf("%d %d",&m,&n),n)
    {
		int x,y;  
        memset(v,0,sizeof(v));//把v里的数全部替换为零 ,头文件为<string.h>   
        for(int i=0;i<n;i++)  
        	scanf("%s",a[i]);    
        	for(int i=0;i<n;i++)  
        		for(int j=0;j<m;j++)  
        			if(a[i][j] == '@')   
       			 	x= i,y= j;
       	ans=0;
       	dfs(x,y);
   		printf("%d\n",ans);  
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值