<poj 1046>Color Me Less

                                                                                                                                             Color Me Less
 
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25873 Accepted: 12417

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

Sample Output

(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)

Source

 
暴力解决……
AC Code:
 
#include <stdio.h>
#include <math.h>
using namespace std;

struct TargetSet
{
    int R;
    int G;
    int B;
}c[17];

int main()
{
    int i,MinD,D,r,g,b;
    for(i=0;i<16;i++)
    {
        scanf("%d%d%d",&c[i].R,&c[i].G,&c[i].B);
    }
    while(scanf("%d%d%d",&r,&g,&b) && r!=-1)
    {
        MinD=0xfffff;
        for(i=0;i<16;i++)
        {
            D=pow((c[i].R-r)*(c[i].R-r)+(c[i].G-g)*(c[i].G-g)+(c[i].B-b)*(c[i].B-b),0.5);
            if(MinD>D)
            {
                MinD=D;
                c[16].B=c[i].B;
                c[16].G=c[i].G;
                c[16].R=c[i].R;
                if(MinD==0) break;
            }
        }
        printf("(%d,%d,%d) maps to (%d,%d,%d)\n",r,g,b,c[16].R,c[16].G,c[16].B);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值