Clock||HDU1209

link:http://acm.hdu.edu.cn/showproblem.php?pid=1209

Problem Description

There is an analog clock with two hands: an hour hand and a minute hand. The two hands form an angle. The angle is measured as the smallest angle between the two hands. The angle between the two hands has a measure that is greater than or equal to 0 and less than or equal to 180 degrees.

Given a sequence of five distinct times written in the format hh : mm , where hh are two digits representing full hours (00 <= hh <= 23) and mm are two digits representing minutes (00 <= mm <= 59) , you are to write a program that finds the median, that is, the third element of the sorted sequence of times in a nondecreasing order of their associated angles. Ties are broken in such a way that an earlier time precedes a later time.

For example, suppose you are given a sequence (06:05, 07:10, 03:00, 21:00, 12:55) of times. Because the sorted sequence is (12:55, 03:00, 21:00, 06:05, 07:10), you are to report 21:00.

Input

The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. Each test case is given on a single line, which contains a sequence of five distinct times, where times are given in the format hh : mm and are separated by a single space.

Output

Print exactly one line for each test case. The line is to contain the median in the format hh : mm of the times given. The following shows sample input and output for three test cases.

Sample Input

3
00:00 01:00 02:00 03:00 04:00
06:05 07:10 03:00 21:00 12:55
11:05 12:05 13:05 14:05 15:05

Sample Output

02:00
21:00
14:05

题解:注意角度的算法

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;

struct time
{
    int hour;
    int minute;
    double angle;
    int c;
}q[5];
bool cmp(time a,time b)
{
    if(a.angle!=b.angle)
    return a.angle<b.angle;
    return a.hour<b.hour;//角度相同按小时数小的放前面 
}
int main()
{
    int t,i,s,c,x,n;
    scanf("%d",&t);
    while(t--)
    {
        for(i=0;i<5;i++)
        {
            scanf("%d:%d",&q[i].hour,&q[i].minute);
            if(q[i].hour>12)
            {
                q[i].hour-=12;
                q[i].c=1;
            }
            else q[i].c=0;
            q[i].angle=fabs(q[i].hour*30+q[i].minute*0.5-q[i].minute*6);
            //角度的算法 
            if(q[i].angle>180)
            {
                q[i].angle=360-q[i].angle;
            }
            if(q[i].c) q[i].hour+=12;
        }
        sort(q,q+5,cmp);
        printf("%02d:%02d\n",q[2].hour,q[2].minute);

    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值