centos 6.4 不能使用yum install 的问题

在青云上创建centos 6.4后,习惯性的安装emacs. 结果遇到报错信息:

# yum install emacs
Loaded plugins: fastestmirror
Determining fastest mirrors
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

解决方法是更新ca-certificates

# yum upgrade ca-certificates --disablerepo=epel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.skyshe.cn
 * extras: ftp.sjtu.edu.cn
 * rpmfusion-free-updates: ftp.sjtu.edu.cn
 * rpmfusion-nonfree-updates: ftp.sjtu.edu.cn
 * updates: mirrors.skyshe.cn
base                                                                                                                                                                   | 3.7 kB     00:00     
base/primary_db                                                                                                                                                        | 4.6 MB     00:04     
emacs                                                                                                                                                                  | 2.9 kB     00:02     
emacs/primary_db                                                                                                                                                       |  37 kB     00:01     
extras                                                                                                                                                                 | 3.4 kB     00:00     
extras/primary_db                                                                                                                                                      |  37 kB     00:00     
rpmfusion-free-updates                                                                                                                                                 | 2.7 kB     00:00     
rpmfusion-free-updates/primary_db                                                                                                                                      | 272 kB     00:00     
rpmfusion-nonfree-updates                                                                                                                                              | 2.2 kB     00:00     
rpmfusion-nonfree-updates/primary_db                                                                                                                                   |  65 kB     00:00     
updates                                                                                                                                                                | 3.4 kB     00:00     
updates/primary_db                                                                                                                                                     | 5.2 MB     00:05     
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package ca-certificates.noarch 0:2010.63-3.el6_1.5 will be updated
---> Package ca-certificates.noarch 0:2015.2.6-65.0.1.el6_7 will be an update
--> Processing Dependency: p11-kit-trust >= 0.18.4-2 for package: ca-certificates-2015.2.6-65.0.1.el6_7.noarch
--> Processing Dependency: p11-kit >= 0.18.4-2 for package: ca-certificates-2015.2.6-65.0.1.el6_7.noarch
--> Running transaction check
---> Package p11-kit.x86_64 0:0.18.5-2.el6_5.2 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: p11-kit-0.18.5-2.el6_5.2.x86_64
--> Processing Dependency: libtasn1.so.3()(64bit) for package: p11-kit-0.18.5-2.el6_5.2.x86_64
---> Package p11-kit-trust.x86_64 0:0.18.5-2.el6_5.2 will be installed
--> Running transaction check
---> Package libtasn1.x86_64 0:2.3-6.el6_5 will be installed
--> Processing Conflict: p11-kit-trust-0.18.5-2.el6_5.2.x86_64 conflicts nss < 3.14.3-33
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
--> Processing Dependency: nss = 3.14.0.0-12.el6 for package: nss-tools-3.14.0.0-12.el6.x86_64
--> Processing Dependency: nss = 3.14.0.0-12.el6 for package: nss-sysinit-3.14.0.0-12.el6.x86_64
---> Package nss.x86_64 0:3.21.0-0.3.el6_7 will be an update
--> Processing Dependency: nss-util >= 3.21.0 for package: nss-3.21.0-0.3.el6_7.x86_64
--> Processing Dependency: nss-softokn(x86-64) >= 3.14.3-22 for package: nss-3.21.0-0.3.el6_7.x86_64
--> Processing Dependency: nspr >= 4.11.0 for package: nss-3.21.0-0.3.el6_7.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.21)(64bit) for package: nss-3.21.0-0.3.el6_7.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.17.1)(64bit) for package: nss-3.21.0-0.3.el6_7.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.15)(64bit) for package: nss-3.21.0-0.3.el6_7.x86_64
--> Running transaction check
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.11.0-0.1.el6_7 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-23.el6_7 will be an update
--> Processing Dependency: nss-softokn-freebl(x86-64) >= 3.14.3-23.el6_7 for package: nss-softokn-3.14.3-23.el6_7.x86_64
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.21.0-0.3.el6_7 will be an update
--> Running transaction check
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.14.3-23.el6_7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================
 Package                                           Arch                                  Version                                                 Repository                              Size
==============================================================================================================================================================================================
Updating:
 ca-certificates                                   noarch                                2015.2.6-65.0.1.el6_7                                   updates                                1.2 M
 nss                                               x86_64                                3.21.0-0.3.el6_7                                        updates                                858 k
Installing for dependencies:
 libtasn1                                          x86_64                                2.3-6.el6_5                                             base                                   238 k
 p11-kit                                           x86_64                                0.18.5-2.el6_5.2                                        base                                    94 k
 p11-kit-trust                                     x86_64                                0.18.5-2.el6_5.2                                        base                                    71 k
Updating for dependencies:
 nspr                                              x86_64                                4.11.0-0.1.el6_7                                        updates                                114 k
 nss-softokn                                       x86_64                                3.14.3-23.el6_7                                         updates                                262 k
 nss-softokn-freebl                                x86_64                                3.14.3-23.el6_7                                         updates                                167 k
 nss-sysinit                                       x86_64                                3.21.0-0.3.el6_7                                        updates                                 46 k
 nss-tools                                         x86_64                                3.21.0-0.3.el6_7                                        updates                                435 k
 nss-util                                          x86_64                                3.21.0-0.3.el6_7                                        updates                                 67 k

Transaction Summary
==============================================================================================================================================================================================
Install       3 Package(s)
Upgrade       8 Package(s)

Total download size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/11): ca-certificates-2015.2.6-65.0.1.el6_7.noarch.rpm                                                                                                               | 1.2 MB     00:01     
(2/11): libtasn1-2.3-6.el6_5.x86_64.rpm                                                                                                                                | 238 kB     00:00     
(3/11): nspr-4.11.0-0.1.el6_7.x86_64.rpm                                                                                                                               | 114 kB     00:00     
(4/11): nss-3.21.0-0.3.el6_7.x86_64.rpm                                                                                                                                | 858 kB     00:00     
(5/11): nss-softokn-3.14.3-23.el6_7.x86_64.rpm                                                                                                                         | 262 kB     00:00     
(6/11): nss-softokn-freebl-3.14.3-23.el6_7.x86_64.rpm                                                                                                                  | 167 kB     00:00     
(7/11): nss-sysinit-3.21.0-0.3.el6_7.x86_64.rpm                                                                                                                        |  46 kB     00:00     
(8/11): nss-tools-3.21.0-0.3.el6_7.x86_64.rpm                                                                                                                          | 435 kB     00:00     
(9/11): nss-util-3.21.0-0.3.el6_7.x86_64.rpm                                                                                                                           |  67 kB     00:00     
(10/11): p11-kit-0.18.5-2.el6_5.2.x86_64.rpm                                                                                                                           |  94 kB     00:00     
(11/11): p11-kit-trust-0.18.5-2.el6_5.2.x86_64.rpm                                                                                                                     |  71 kB     00:00     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                         601 kB/s | 3.5 MB     00:06     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : nspr-4.11.0-0.1.el6_7.x86_64                                                                                                                                              1/19 
  Updating   : nss-util-3.21.0-0.3.el6_7.x86_64                                                                                                                                          2/19 
  Updating   : nss-softokn-freebl-3.14.3-23.el6_7.x86_64                                                                                                                                 3/19 
  Updating   : nss-softokn-3.14.3-23.el6_7.x86_64                                                                                                                                        4/19 
  Updating   : nss-sysinit-3.21.0-0.3.el6_7.x86_64                                                                                                                                       5/19 
  Updating   : nss-3.21.0-0.3.el6_7.x86_64                                                                                                                                               6/19 
  Installing : libtasn1-2.3-6.el6_5.x86_64                                                                                                                                               7/19 
  Installing : p11-kit-0.18.5-2.el6_5.2.x86_64                                                                                                                                           8/19 
  Installing : p11-kit-trust-0.18.5-2.el6_5.2.x86_64                                                                                                                                     9/19 
  Updating   : ca-certificates-2015.2.6-65.0.1.el6_7.noarch                                                                                                                             10/19 
  Updating   : nss-tools-3.21.0-0.3.el6_7.x86_64                                                                                                                                        11/19 
  Cleanup    : ca-certificates-2010.63-3.el6_1.5.noarch                                                                                                                                 12/19 
  Cleanup    : nss-tools-3.14.0.0-12.el6.x86_64                                                                                                                                         13/19 
  Cleanup    : nss-3.14.0.0-12.el6.x86_64                                                                                                                                               14/19 
  Cleanup    : nss-sysinit-3.14.0.0-12.el6.x86_64                                                                                                                                       15/19 
  Cleanup    : nss-softokn-3.12.9-11.el6.x86_64                                                                                                                                         16/19 
  Cleanup    : nss-util-3.14.0.0-2.el6.x86_64                                                                                                                                           17/19 
  Cleanup    : nspr-4.9.2-1.el6.x86_64                                                                                                                                                  18/19 
  Cleanup    : nss-softokn-freebl-3.12.9-11.el6.x86_64                                                                                                                                  19/19 
  Verifying  : p11-kit-0.18.5-2.el6_5.2.x86_64                                                                                                                                           1/19 
  Verifying  : nss-util-3.21.0-0.3.el6_7.x86_64                                                                                                                                          2/19 
  Verifying  : nss-softokn-3.14.3-23.el6_7.x86_64                                                                                                                                        3/19 
  Verifying  : nss-softokn-freebl-3.14.3-23.el6_7.x86_64                                                                                                                                 4/19 
  Verifying  : nss-sysinit-3.21.0-0.3.el6_7.x86_64                                                                                                                                       5/19 
  Verifying  : libtasn1-2.3-6.el6_5.x86_64                                                                                                                                               6/19 
  Verifying  : nss-3.21.0-0.3.el6_7.x86_64                                                                                                                                               7/19 
  Verifying  : ca-certificates-2015.2.6-65.0.1.el6_7.noarch                                                                                                                              8/19 
  Verifying  : nspr-4.11.0-0.1.el6_7.x86_64                                                                                                                                              9/19 
  Verifying  : nss-tools-3.21.0-0.3.el6_7.x86_64                                                                                                                                        10/19 
  Verifying  : p11-kit-trust-0.18.5-2.el6_5.2.x86_64                                                                                                                                    11/19 
  Verifying  : nss-tools-3.14.0.0-12.el6.x86_64                                                                                                                                         12/19 
  Verifying  : nss-3.14.0.0-12.el6.x86_64                                                                                                                                               13/19 
  Verifying  : ca-certificates-2010.63-3.el6_1.5.noarch                                                                                                                                 14/19 
  Verifying  : nss-softokn-freebl-3.12.9-11.el6.x86_64                                                                                                                                  15/19 
  Verifying  : nss-util-3.14.0.0-2.el6.x86_64                                                                                                                                           16/19 
  Verifying  : nss-sysinit-3.14.0.0-12.el6.x86_64                                                                                                                                       17/19 
  Verifying  : nspr-4.9.2-1.el6.x86_64                                                                                                                                                  18/19 
  Verifying  : nss-softokn-3.12.9-11.el6.x86_64                                                                                                                                         19/19 

Dependency Installed:
  libtasn1.x86_64 0:2.3-6.el6_5                             p11-kit.x86_64 0:0.18.5-2.el6_5.2                             p11-kit-trust.x86_64 0:0.18.5-2.el6_5.2                            

Updated:
  ca-certificates.noarch 0:2015.2.6-65.0.1.el6_7                                                         nss.x86_64 0:3.21.0-0.3.el6_7                                                        

Dependency Updated:
  nspr.x86_64 0:4.11.0-0.1.el6_7              nss-softokn.x86_64 0:3.14.3-23.el6_7         nss-softokn-freebl.x86_64 0:3.14.3-23.el6_7         nss-sysinit.x86_64 0:3.21.0-0.3.el6_7        
  nss-tools.x86_64 0:3.21.0-0.3.el6_7         nss-util.x86_64 0:3.21.0-0.3.el6_7          

Complete!

现在可以了。



已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页