Pat(Advanced Level)Practice--1082(Read Number in Chinese)

Pat1082代码

题目描述:

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

AC代码:
#include<cstdio>
#include<string>
#include<vector>

using namespace std;

int main(int argc,char *argv[])
{
	string d[]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
	string w[]={"0","Shi","Bai","Qian","Wan","Shi","Bai","Qian","Yi"};
	vector<string> ans;
	vector<int> num;
	int n,e;
	scanf("%d",&n);
	if(n==0)
	{
		printf("ling\n");
		return 0;
	}
	else if(n<0)
	{
		printf("Fu ");
		n=-n;
	}
	while(n)
	{
		num.push_back(n%10);
		n/=10;
	}
	e=0;
	while(e<num.size()&&num[e]==0)
	{
		e++;
	}
	if(e==8)
	{
		printf("%s Yi\n",d[num[e]].c_str());
		return 0;
	}
	for(int i=e;i<num.size();i++)
	{
		if(i!=0&&(num[i]!=0||i==4||i==8))
		{
			ans.push_back(w[i]);
		}
		ans.push_back(d[num[i]]);
	}
	for(int i=ans.size()-1;i>=0;i--)
	{
		if(i!=ans.size()-1)
			printf(" ");
		int cnt=0;
		while(i>=0&&ans[i]=="ling")
		{
			--i;
			++cnt;
		}
		if(cnt!=0&&ans[i]!="Wan")
		{
			printf("ling ");
		}
		printf("%s",(ans[i]).c_str());
	}
	printf("\n");

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值