A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".
For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 10 CYLL 01:01:06:01 on-line CYLL 01:28:16:05 off-line CYJJ 01:01:07:00 off-line CYLL 01:01:08:03 off-line CYJJ 01:01:05:59 on-line aaa 01:01:01:03 on-line aaa 01:02:00:01 on-line CYLL 01:28:15:41 on-line aaa 01:05:02:24 on-line aaa 01:04:23:59 off-lineSample Output:
CYJJ 01 01:05:59 01:07:00 61 $12.10 Total amount: $12.10 CYLL 01 01:06:01 01:08:03 122 $24.40 28:15:41 28:16:05 24 $3.85 Total amount: $28.25 aaa 01 02:00:01 04:23:59 4318 $638.80 Total amount: $638.80
- #include<iostream>
- #include<cstdio>
- #include<memory.h>
- #include<algorithm>
- #include<cstring>
- #include<queue>
- #include<cmath>
- #include<vector>
- #include<cstdlib>
- #include<cmath>
- #include<iomanip>
- #include<string>
- #include<map>
- using namespace std;
- struct Node{
- int mon;
- int state;
- int d, h, m;
- bool operator<(const Node & node)const{
- if(d!=node.d)
- return d<node.d;
- if(h!=node.h)
- return h<node.h;
- if(m!=node.m)
- return m<node.m;
- return false;
- }
- };
- struct Record{
- int mon;
- int sd, sh, sm;
- int ed, eh, em;
- };
- struct Res{
- string name;
- vector<Record> records;
- bool operator<(const Res& res)const{
- return name<res.name;
- }
- };
- map<string, vector<Node> > rs;
- map<string, vector<Node> >::iterator it;
- map<string, vector<Record> > ans;
- map<string, vector<Record> >::iterator it2;
- int charge[25];
- int chargeByTime(int time)
- {
- int hours = time/60;
- int minutes = time%60;
- int money = 0;
- int i;
- for(i = 0;i<hours;i++)
- money += charge[i%24]*60;
- money += charge[i%24]*minutes;
- return money;
- }
- double getcharge(int sd, int sh, int sm, int ed, int eh, int em){
- return (chargeByTime(ed*24*60+eh*60+em)-chargeByTime(sd*24*60+sh*60+sm))/100.0;
- }
- int main(){
- freopen("in.txt", "r", stdin);
- for(int i=0;i<24;++i){
- scanf("%d", charge+i);
- }
- int n;
- string s;
- char ss[10];
- cin>>n;
- int mon;
- for(int i=0;i<n;++i){
- cin>>s;
- Node node;
- scanf("%d:%d:%d:%d %s", &mon, &node.d, &node.h, &node.m, ss );
- if(!strcmp(ss, "on-line"))
- node.state = 1;
- else
- node.state = 2;
- node.mon = mon;
- rs[s].push_back(node);
- }
- it = rs.begin();
- while(it!=rs.end()){
- vector<Node> v = it->second;
- sort(v.begin(), v.end());
- bool flag = false;
- Record record;
- for(int i=0;i<v.size();++i){
- if(v[i].state==1){
- flag = true;
- record.sd = v[i].d;
- record.sh = v[i].h;
- record.sm = v[i].m;
- record.mon = v[i].mon;
- }else{
- if(flag){
- flag = false;
- record.ed = v[i].d;
- record.eh = v[i].h;
- record.em = v[i].m;
- ans[it->first].push_back(record);
- }
- }
- }
- it++;
- }
- it2 = ans.begin();
- vector<Res> res;
- while(it2!=ans.end()){
- Res r;
- r.name = it2->first;
- r.records = it2->second;
- it2++;
- res.push_back(r);
- }
- sort(res.begin(), res.end());
- for(int i=0;i<res.size();++i){
- vector<Record> records = res[i].records;
- cout<<res[i].name<<" "<<setw(2)<<setfill('0')<<records[0].mon<<endl;
- double ans = 0;
- for(int i=0;i<records.size();++i){
- cout<<setw(2)<<setfill('0')<<records[i].sd<<":"<<setw(2)<<setfill('0')<<records[i].sh<<":"<<setw(2)<<setfill('0')<<records[i].sm;
- cout<<" "<<setw(2)<<setfill('0')<<records[i].ed<<":"<<setw(2)<<setfill('0')<<records[i].eh<<":"<<setw(2)<<setfill('0')<<records[i].em;
- double c = getcharge(records[i].sd, records[i].sh, records[i].sm, records[i].ed, records[i].eh, records[i].em);
- int time = (records[i].ed-records[i].sd)*24*60 + (records[i].eh-records[i].sh)*60 + records[i].em - records[i].sm;
- cout<<" "<<time;
- printf(" $%.2lf\n", c);
- ans += c;
- }
- printf("Total amount: $%.2lf\n", ans);
- }
- fclose(stdin);
- return 0;
- }