-
题目描述:
-
现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。
-
输入:
-
测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为:
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。
-
输出:
-
对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。
-
样例输入:
-
1 S 08:10 2 S 08:35 1 E 10:00 2 E 13:16 0 S 17:00 0 S 17:00 3 E 08:10 1 S 08:20 2 S 09:00 1 E 09:20 0 E 17:00 -1
-
样例输出:
-
2 196 0 0 1 60
- #include<iostream>
- #include<cstdio>
- #include<cstdlib>
- #include<memory.h>
- #include<map>
- #define MAX 0xFFFFFFF
- using namespace std;
- struct Node{
- int sh, sm, eh, em;
- int no;
- };
- Node nodes[101];
- int main(){
- //freopen("in.txt", "r", stdin);
- int no,h,m;
- char ch;
- while(scanf("%d %c %d:%d", &no, &ch, &h, &m)!=EOF){
- if(no==0){
- int times = 0;
- double total = 0;
- int sum = 0;
- int res;
- for(int i=0;i<101;++i){
- if(nodes[i].sh!=0 && nodes[i].eh!=0){
- total += 60*(nodes[i].eh - nodes[i].sh) + nodes[i].em - nodes[i].sm;
- times++;
- }
- }
- if(total==0){
- printf("0 0\n");
- continue;
- }
- sum = total;
- res = sum/times+(total/times - sum/times >= 0.5?1:0);
- printf("%d %d\n", times, res);
- memset(nodes, 0, sizeof(nodes));
- }
- if(ch=='S'){
- nodes[no].sh = h;
- nodes[no].sm = m;
- }else{
- nodes[no].eh = h;
- nodes[no].em = m;
- }
- }
- //fclose(stdin);
- }