Monkey and Banana(zoj1093)

题目:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer  n ,
representing the number of different blocks in the following data set. The maximum value for  n  is 30.
Each of the next  n  lines contains three integers representing the values  xi yi  and  zi .
Input is terminated by a value of zero (0) for  n .

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case  case : maximum height =  height "

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

一道动态规划的水题,可以将其问题转化为图的形式,然后求最长路径,用G[][]数组来标记两个方块之间是否单向联通,联通就代表一个方块能放在另一方块上面然后再注意的是用d【】数组记录已经算过的dp(),可以减少运行时间

以下是ac代码:

    #include<stdio.h>
    #include<iostream>
    #include<string>
    #include<string.h>
    using namespace std;

     int n,G[100][100],d[100], zhuan[100];

    int dp(int i)
    {

        int ans=0;
        if(d[i]!=-1)
            {ans=d[i];}
        else{
          for(int j=0;j<3*n;j++)
           {
              if(i!=j && G[i][j]==1)
               {
                   int c=dp(j);
                   ans=c>ans?c:ans;
               }
           }
           ans+=zhuan[i];
        }
        d[i]=ans;

        return ans;
    }
    int main()
    {
        int k=0;
        cin>>n;
        while(n!=0)
        {
            k++;
            memset(G,0,sizeof(G));
            memset(d,-1,sizeof(d));
            int x[35],y[35],z[35];
            int  row[100],cl[100],h[100];
            for(int i=0;i<n;i++)
            {
                cin>>x[i]>>y[i]>>z[i];
                zhuan[i*3]=x[i];row[i*3]=y[i]<z[i]?y[i]:z[i];cl[i*3]=y[i]>z[i]?y[i]:z[i];
                 zhuan[i*3+1]=y[i];row[i*3+1]=x[i]<z[i]?x[i]:z[i];cl[i*3+1]=x[i]>z[i]?x[i]:z[i];
                  zhuan[i*3+2]=z[i];row[i*3+2]=y[i]<x[i]?y[i]:x[i];cl[i*3+2]=y[i]>x[i]?y[i]:x[i];


            }
            for(int i=0;i<n*3;i++)
            {
                for(int j=0;j<n*3;j++)
                {
                    if(row[i]==row[j]&&cl[i]==cl[j])
                        continue;
                    if(row[i]<row[j]  && cl[i]<cl[j] )
                        G[i][j]=1;
                }
            }
            int   mmax=0;
            for(int i=0;i<n*3;i++)
            {
                int mm=dp(i);
                if(mm>mmax)
                    {mmax=mm;}
            }
            cout<<"Case "<<k<<": "<<"maximum height = ";
            cout<<mmax<<endl;
            cin>>n;
        }
        return 0;
    }


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值