3.3 回溯法

poj 1979

Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.  

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.  

'.' - a black tile  
'#' - a red tile  
'@' - a man on a black tile(appears exactly once in a data set)  
The end of the input is indicated by a line consisting of two zeros.  

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

package data20180306;


import java.util.Scanner;
//a-1>=0 count next nextLine nextInt  getChar()
public class RedAndBlack {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int w = cin.nextInt();
        int h = cin.nextInt();
        cin.nextLine();
    
        while(w!=0&&h!=0){
            int a=0,b=0,count=0;
            char[][] t = new char[h][w];
            int[][] flag = new int[h][w];
            for(int i=0;i<h;i++){
                String s =cin.nextLine();
                for(int j=0;j<w;j++){
                    flag[i][j]=0;
                    t[i][j]=s.charAt(j);
                    if(t[i][j]=='@'){
                        a=i;
                        b=j;
                    }
                }
            }
            count = find(t,flag,h,w,a,b,count);
            
            
            System.out.println(count);
             w = cin.nextInt();
             h = cin.nextInt();
             cin.nextLine();
        }    
    
    }
    
    public static int find(char[][] t,int[][] flag,int h,int w,int a,int b,int count){
        
        if(t[a][b]=='#'){
            return count;
        }else{
        if(flag[a][b]==0){
            count++;
            flag[a][b]=1;
            for(int i=0;i<4;i++){
                switch(i){
                    case 0:
                        if((a-1)>=0){
                            count=find(t,flag,h,w,a-1,b,count);
                        }
                        break;
                    case 1:
                        if((a+1)<h){
                            count=find(t,flag,h,w,a+1,b,count);
                        }
                        break;
                    case 2:
                        if((b-1)>=0){
                            count=find(t,flag,h,w,a,b-1,count);
                        }
                        break;
                    case 3:
                        if((b+1)<w){
                            count=find(t,flag,h,w,a,b+1,count);
                        }
                }
            }
        }else{
            return count;
        }
        }
        return count;
        
        
        
        
        
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值